Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by witoco
Yep...
witoco
Coordinators
Coordinators
Posts: 982
Has thanked: 83 times
Been thanked: 162 times
Attachments

Post by YanisKyr
Not sure if this has been mentioned but I can't find anything - what does the length of the dashed highlights represent?



Fullsize
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
Would it be possible to add a shortcut option to enable/disable the script?
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
jm6087 wrote:
YanisKyr wrote:Would it be possible to add a shortcut option to enable/disable the script?
Do you mean something like this?
This is the toggle I'm talking about, yes, but I was referring to a keyboard shortcut. These 3 are currently available:
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
jm6087 wrote: I believe that YanisKyr would like a 4th shortcut added to the list, one that will disable entire script as opposed to just the 3 categories.
That's it, thank you!
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
Can I ask, will it still auto-update?
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
SkiDooGuy wrote:<Edit> Original post from the beta lanes forum merged into this topic See This Post for the most recent information>

LaneTools is a script that provides both visual map and interface enhancements and tools.
FYI, the link in post #1 is also broken. It seems to have a space instead of a dash in "WME-LaneTools".
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
I'm getting this too this afternoon, even with the previous version before I manually updated.

I think it's not just the font - the tickboxes don't do anything. If you try the enable/disable one at the top, the script doesn't run.
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times

Post by YanisKyr
I'd like to mention one small issue and also suggest a new feature:

- A space missing between the direction and the street name. e.g: Drive north onStreet name.
- There are cases where the default Turn Instruction is Turn Left/Right but the default Lane Turn Suggestion is a Sharp Left/Right or Slight Left/Right. Would it be possible to highlight segments or nodes with LG that fall under this conundrum?



Default Turn Instructions for the above junction displayed with WME Junction Angle Info (dark green = Turn):
YanisKyr
Posts: 551
Has thanked: 308 times
Been thanked: 78 times