Post Reply

New Editor version 2.109

Post by nataliiaPi
Hi Everyone,

We've released a new WME editor v2.109.

Looking forward to your feedback!   :geek:
 

Quick Overview (more details below).


Known issues:
  • Left panel alert taking too much space in WME. - The team is still working on this, the problem is complex and requires more engineering effort. Sorry for the inconvenience.
  • Share location menu: Share Button text invisible.
  • Unable to change the case (upper / lower) of an existing street.
  • Unable to see direction of a closed segment if you cannot edit the segment.

Community suggestion: 
  • Display all routing options without using dropdown buttons in the segment panel.

Bug Fixes:
  • "Enter" button doesn't apply address' changes. 
  •  "H" hotkey doesn't open House Numbers mode.
  • Link to the Waze events page instead points back to the WME.
  • Issue with "no city" on alt addresses of segments.
  • TBRs not possible to set on Junction Box pathes.
  • Gas Station Brand / PL operator couldn't be deleted.
  • Long drives not visible in Beta.
  • Roadshield applies to the original road name if the segment is not reselected.
  • RTCs via mobile browser can't be added if you have to select "none" for the event.
  • Changing city to non existing one when updating alt address doesn't trigger the confirm popup.
  • Deleting alternative address also deletes the primary address (when no common street).
  • PURs: place update panel doesn't show the last PUR of a place (for venues with multiple PURs). 
  • Venue: submitting main address form doesn't close add alt street form. 
  • Prevent submitting address change if no actual changes were made.
  • Segments: it is impossible to set "None" for city for the Alternative Address

New features/enhancements: 
  • Move segment IDs to the bottom of the WME left panel and add a button to hide and view the segment IDs.
  • Remove the "node icon" from the closure nodes.
  • Design enhancements: align venue sidebar styles.
  • Show address by pressing the "E" button, when the segment or any other object on the map is selected.
  • New icons to venue header menu.
  • Text added to buttons, which define the geometry type for Map comments.
  • Update history main object styles and the empty state view.
  • Update error message when editing in snapshot mode : We no longer use the term 'snapshot mode' we call this the 'previous map build.
  • New elements of the top menu control panel were added.



 
This is the link to the release notes.

Thank you,
Nataliia

 
 
 
 
nataliiaPi
Waze Team
Waze Team
Posts: 370
Has thanked: 99 times
Been thanked: 222 times

POSTER_ID:17884482

1

Send a message

Post by linguasaltitante
nataliiaPi wrote: Mon Aug 15, 2022 12:47 pm In the meantime I want to ask: is this blocking critical work that you can only do on Android/Firefox or you can use Chrome browser for the same tasks? 
 
We want to understand the impact of the problem. 

Thank you in advance,
Nataliia 
 
I use Edge on WIN11 and I'm not facing any obvious problems ... (just the ones related with broken scripts  :?
 
 
 
linguasaltitante
Map Editor - Level 5
Map Editor - Level 5
Posts: 304
Has thanked: 78 times
Been thanked: 141 times
Send a message


Post by linguasaltitante
nataliiaPi wrote: Wed Aug 17, 2022 9:33 am
linguasaltitante wrote: Wed Aug 17, 2022 8:52 am Hello

There seems to be a problem when creating an Event: it does not assume the city that is firstly shown by default




 
Hi Linguasaltitante,

Thank you for the report. Could you please check this forum thread? It seems that these issues are similar. 

Regards,
Nataliia

 
Hello nataliiaPi

It's the same issue. Sorry, I was not aware of that thread  :oops:

Best regards 
 
linguasaltitante
Map Editor - Level 5
Map Editor - Level 5
Posts: 304
Has thanked: 78 times
Been thanked: 141 times
Send a message

Post by linguasaltitante
nataliiaPi wrote: Wed Aug 17, 2022 10:07 am Hey Linguasaltitante,

No worries, thank you once again for the report.

Have a nice day!
Nataliia

 
Nataliia, since we are talking about Events (and hoping that this wasn't already also a reason of another thread reporting the same issue  :oops: ) please see the GIF below.

Being I a member of Portuguese localization team, I can apply some kind of abbreviation to allow the language to fit on the drop box, but as you can see, there are another languages that do not fit on the drop box. In what concerns the Portuguese language, we can't distinguish between Brazil and Portugal so, in the end, the editor do not know which language is selecting. This must be revised, by changing the font size, making the drop box bigger, whatever ... 
 
Best regards 


https://gcdnb.pbrd.co/images/UiKJ7EtUxzsw.gif?o=1
linguasaltitante
Map Editor - Level 5
Map Editor - Level 5
Posts: 304
Has thanked: 78 times
Been thanked: 141 times
Send a message

Post by locojd1
In the New Version we still experiencing an issue when closing a PUR or a UR the windows don't closed automatically after saving.
locojd1
Area Manager
Area Manager
Posts: 859
Has thanked: 412 times
Been thanked: 126 times
Send a message
Area Manager: Peel Region / Greater Toronto Area
Area Manager: New Mexico / North Carolina
LATAM Area Manager: Cuba / Medellin
USA-Mexico Border

Thank you,
Juan

https://s.waze.tools/c3s.pnghttps://imgur.com/gwgbGJv.pnghttps://imgur.com/gISoB75.pnghttps://imgur.com/LUqRDBb.png

Post by massic80
SC1GHERA wrote: Thu Aug 11, 2022 1:32 pm Hi Nataliia,

I currently use Firefox 103.0.2 on my main computer, and I use 102.0.1 on my laptop - both versions exhibit the issue of being stuck at Loading.

I can confirm that I am still experiencing the Content-Security-Policy issue:

 
 
 

 
The same on 104 Beta
 
massic80
Posts: 2
Has thanked: 2 times
Send a message

Post by nataliiaPi
SC1GHERA wrote: Wed Aug 10, 2022 3:47 pm Hi there,

This new Editor version does not seem to work on Firefox and results in the loading spinner just being shown indefinitely.

....


 
Hi SC1GHERA,

Could you please tell which Fire Fox version do you use? 

Thank you,
Nataliia
 
 
nataliiaPi
Waze Team
Waze Team
Posts: 370
Has thanked: 99 times
Been thanked: 222 times
Send a message

Post by nataliiaPi
G_W1Z wrote: Wed Aug 10, 2022 5:00 pm After approving a Place Update Request (PUR) and saving, the PUR window remains open. Here is what it looks like:Screenshot 2022-08-10 125714.png

This is happening with all scripts/extensions disabled. 

Here is a PL to a place I had this happen with: https://www.waze.com/en-US/editor?env=u ... 11.1431437

I tested in the general area with other types of PURs (adding a new place, for example) and the same behavior occured.
 

 
Hi G_W1Z,

Thank you for this report. Sorry, I am not experienced with approving PURs, what is the expected behaviour? Should the PUR window be closed after pressing "approved"? 

Regards,
Nataliia
 
 
nataliiaPi
Waze Team
Waze Team
Posts: 370
Has thanked: 99 times
Been thanked: 222 times
Send a message

Post by nataliiaPi
G_W1Z wrote: Thu Aug 11, 2022 11:55 am Once they are approved or rejected, the window remains displayed but once you click save the window closes (since the task with that PUR is now complete.) 
 


 
Thank you G_W1Z. And I see that there is an additional button "Done" on the screen with the PUR. Is it possible to click on it? 

Regards,
Nataliia
 
nataliiaPi
Waze Team
Waze Team
Posts: 370
Has thanked: 99 times
Been thanked: 222 times
Send a message