[Script] Highlights for Segments & Landmarks - v1.5 Nov 16

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderators: Unholy, bextein

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby CBenson » Wed Sep 05, 2012 1:36 pm

Timbones wrote:
chrysrobyn wrote:What do you think about adding a color option for null nodes (nodes joining two segments that are identical in type, direction, state and city with no real intersection)?

While these are superfluous nodes, they don't really affect routing and so don't need to be deleted.

Are we sure about this? There seems to be some evidence to the contrary.
Regional Coordinator: Mid-Atlantic, US
Verizon, Nexus 6, Android 6.0.1, Waze 4.7.0.902
CBenson
Waze Global Champs
Waze Global Champs
 
Posts: 10295
Joined: Wed Nov 03, 2010 9:13 pm
Location: Crownsville, MD, US
Has thanked: 1063 times
Been thanked: 2339 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby dovos » Wed Sep 05, 2012 1:49 pm

Timbones wrote:
dovos wrote:Can this script add highlights for red segments (a new road recorded via client) - more bright or fat color? It would make appreciable such segments of big scales on the maps

Do you have v1.1? That already makes them bold and red. Do you want them more bright or fat?

Yes, I already install v1.1
Now the transparent pale red of this road is imperceptible on the real red color. I want more bright and fat
Kuhlkatz wrote:I tend to opt for the solid red vs the translucent ;)

+1 :)
Image
dovos
 
Posts: 18
Joined: Thu Aug 05, 2010 12:43 pm
Location: Russia
Has thanked: 1 time
Been thanked: 1 time

Re: Script to add Highlights for Segments & Landmarks - v1.0

Postby Mike-1323 » Wed Sep 05, 2012 9:13 pm

AlanOfTheBerg wrote:
crturboguy wrote:I've noticed a 'bug' in that when this is installed, the save and delete buttons no longer ungrey when they are able to be pressed.

What browser, version and OS are you on? This was never reported during testing.

On a related note, it appears that sometimes the buttons and search bar are disabled sometimes after initial login to the editor. Usually, a permalink click solves the issue. Could you verify whether clicking permalink does or does not make this problem go away?

I had the same issue. I was away from the computer for a while and needed to log in again when I returned to WME. After logging in the buttons wouldn't ungrey. Also, the Advanced options weren't in the highlights tabs. This was on FF14.0.1 with Highlights 1.1.0 running in Vista 64bit.

Reloading the page fixed it all.
Mike-1323
Area Manager
Area Manager
 
Posts: 1026
Joined: Fri Jul 15, 2011 11:06 pm
Location: Lorton, Va
Has thanked: 3 times
Been thanked: 186 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby AlanOfTheBerg » Wed Sep 05, 2012 10:06 pm

I tested logging out of the editor and logging back in with the highlights script enabled and disable and I feel that it is 100% reproducible that with the highlights script enabled and being logged out of the editor, causes the Toolbar to remain inactive after logging in until after clicking on or loading a permalink.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 9.3.2 | Waze v4.7.0.1
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23480
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1085 times
Been thanked: 4610 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby Timbones » Wed Sep 05, 2012 10:12 pm

I've seen this too. Not sure how or why, but I'll look into it...

via mobile
Timbones(6) • UK Coordinator • Forum Moderator • Global Wiki Moderator • Routing Expert
Extensions: WME Colour HighlightsWME Route TesterWME Geometries
Timbones
Coordinators
Coordinators
 
Posts: 6585
Joined: Wed Feb 09, 2011 10:33 am
Location: York, UK
Has thanked: 915 times
Been thanked: 2501 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby AlanOfTheBerg » Wed Sep 05, 2012 10:16 pm

Timbones wrote:I've seen this too. Not sure how or why, but I'll look into it...

I figured you had. I can't logically deduce what could be happening, but something clearly is done differently when not logged in that the script gets in the way of, perhaps by causing some kind of error which prevents the enabling of the toolbar...
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 9.3.2 | Waze v4.7.0.1
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23480
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1085 times
Been thanked: 4610 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby floppyrod84 » Wed Sep 05, 2012 11:31 pm

Looks like it's not allowing the icons to refresh.

Sent from my GT-I9100P using Tapatalk 2
floppyrod84
 
Posts: 2582
Joined: Wed Jan 19, 2011 3:17 pm
Location: Sheerness, Kent, UK
Has thanked: 46 times
Been thanked: 45 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby kentsmith9 » Thu Sep 06, 2012 12:17 am

Timbones wrote:
chrysrobyn wrote:What do you think about adding a color option for null nodes (nodes joining two segments that are identical in type, direction, state and city with no real intersection)?

While these are superfluous nodes, they don't really affect routing and so don't need to be deleted.

Also there are many instances in loops where you need the extra junction, but I guess the script could ignore junctions with segments that meet at both ends.
kentsmith9
Waze Global Champs
Waze Global Champs
 
Posts: 5124
Joined: Mon Apr 23, 2012 3:33 pm
Location: SF/SJ Bay Area of Northern California
Has thanked: 1297 times
Been thanked: 1535 times

Re: Script to add Highlights for Segments & Landmarks - v1.1

Postby mike-bronner » Thu Sep 06, 2012 6:06 am

Hi Tim,
Thank you VERY much for such a useful script. Unfortunately I couldn't get it to work in Safari (even with NinjaKit, the Greasemonkey replacement for Safari) it didn't run. So I set about learning Safari Extensions, and adapted your work as an Extension that works natively in Safari. It can be downloaded here: https://github.com/mikebronner/WME-Color-Highlights.
I gave you full credit, of course, as you did all the heavy lifting. As a Mac user, I have come to prefer Safari over other browsers, and wanted to see it work there too. Please let me know if this is OK with you -- if not, I'll be happy to take it down, or alter it in such a way that would accommodate any changes you request.

Thanks!
~Mike
Image
mike-bronner
 
Posts: 292
Joined: Tue May 24, 2011 12:21 am
Location: Sheridan, Montana, USA
Has thanked: 0 time
Been thanked: 1 time

Script to add Highlights for Segments & Landmarks - v1.1

Postby AlanOfTheBerg » Thu Sep 06, 2012 6:10 am

Super cool mike! I tried to convert it to a native safari extension and couldn't figure it out. I need a tutorial! :)


--
If it looks strange, or I used bad grammar or misspelled anything, it's my phone's fault.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 9.3.2 | Waze v4.7.0.1
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23480
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1085 times
Been thanked: 4610 times

PreviousNext

Return to Waze Map Editor

Who is online

Users browsing this forum: FelipeLemeRJ