Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Post by Trexer0
Within the last month the ability to force the Fancy Permalinks to use beta or production links has disappeared.
Trexer0
Country Manager
Country Manager
Posts: 3640
Answers: 1
Has thanked: 1746 times
Been thanked: 406 times
Send a message

Post by turbomkt
Horizon911 wrote:Hi, Just wonder about the "Redo RA" behavior. I am trying to update this RA but when I use Redo RA, it cuts also those FreeWay segments. (disregarding their different elevation)
Is that intentional? (Or is that something that wants to be fixed or can be configured?)
Can such behavior be avoided without me touching those FW segments? (They are above my editor level + It's extra opportunity to screw up something I did not want to change. :) )
I would ask a senior editor to drag them out of the way before trying to redo the RA - add geohandles and just pull it away. When done, remove any geohandles added to have the FWY snap back to where it was. No need to disconnect anything.
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
Make sure to do at least a soft refresh before removing reverse connections. If the WME thinks they are disconnected, even if it's a bug, the tool will change one way segments to two way.
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
Enable all new turns on new junction doesn't seem to work. That's with 1.9.7 and no scripts running.

JNF/RevCon doesn't seem to work reliably. Thought it was script related as it worked with scripts off, but 50/50 on scripts didn't affect the function. Error provided in TB Beta channel.
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
That has been reported to SkiDooGuy.

In the meantime, you can always use the keyboard shortcuts.
A, S, and Shift+Z in that order.
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
ariksa wrote: Wed May 25, 2022 8:40 pm Hey,
It seems the toolbox makes the Map build status bar to disappear. Is this something I miss?
It shows at the beginning and then disappears right when the toolbox kicks in. Tested without any additional scripts. PROD.
Adding a gif toolbox.gif         
 

 
Did you move the Map build status bar somewhere?  I put mine at the top near the save button.
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
It's intermittent for me. I have been deleting many segments over the last 2 hours without issue. Previous days I have had problems with edits not triggering the count. I can't isolate it to a single cause.

I it possible the Apply button is off screen and you're not actually completing the delete?
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
It's possible that the fact I'm on beta has an effect. However, the beta version hasn't been updated since March so if it does fix things it is most likely by luck. (No offense, Bruce)
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)

Post by turbomkt
ConductorInquieto wrote: Fri Dec 16, 2022 11:39 am Good morning, I hope you can help me.

I have been checking and all the available options are not shown to me, I have tried to uninstall and install again... but I get no result.

Attachment screenshot.Sin título.png

Does anyone have a solution?

In advance, thank you very much.
 
 
 

 
Another thing to consider is rank.  Many features are rank locked, and it varies by country.
turbomkt
Coordinators
Coordinators
Posts: 3770
Answers: 17
Has thanked: 605 times
Been thanked: 745 times
Send a message
--Mike
RC for Northwest Region (NWR Discord)
ARC for Southwest Region (SWR Discord)