Post by pvaladares
Tested after fully uninstalling the previous beta version (3.4.99.109) and deleting the \Waze folder in the sdcard.

BUGS
1 - In the first run of application 3G was being used and there was and the signal was not always good to download the voice prompts. Waze could not skip this download and app became frozen like, after sometime I tried the "back" hard button and the Turn Off message showeduop. However it was not working either.
http://i45.tinypic.com/25fszds.jpg

2 - The favourites were not successfully restored.

3 - If the Settings|General|Events Radius option is changed and thehard button "back" is used the Main Menu will still show the old Events Radius - Waze should force the Menu to refresh (if any option is changed). However if the user use the "X" to close the window then this problem does not occur.

4 - There is some problem displaying special chars
http://i47.tinypic.com/11klapz.jpg

5 - Strings are misaligned
http://i46.tinypic.com/2hxym3d.jpghttp://i48.tinypic.com/m81v0o.jpg

6 - Icons seem to be incorrectly duplicated
http://i50.tinypic.com/jre1pt.jpg

7 - Mood icons are repeated/missing (Gold and Bronze moods are still the same; speedy male/female moods are the same as duck mood; sarcastic female/male moods do not seem to be really that sarcastic)
http://i50.tinypic.com/5f216f.jpghttp://i50.tinypic.com/1pvzgx.jpg

8 - Camera report has the 'send later' and 'take a photo' both disabled
http://i47.tinypic.com/idad7l.jpg

9 - The already available translated text is not being used in the application. Should not you be using the already translated data available @ transifex.com ?

10 - After activating TTS/ASR there is no language to select (Portuguese PT still not supported? It should... it should be forcing to Portuguese BR)


Suggestions
1 - Enable the 'send later' and 'take a photo' in the Map Report

2 - Create the 'Landmark' request in the Map Report

3 - Create a new menu to tweak all configurations available in the preferences file. It could be
accessible only by introducing a code in the navigation

4 - Should be possible to exit the Main menu by taping in the map (3 and 4), not limited to the tiny X (2) or even taping the Main Menu again (1).
http://i47.tinypic.com/2vxge38.jpg

5 - When GPS is not enabled Waze could prompt to open the GPS settings instead of just indicating the steps to manually access the menu in Android
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by pvaladares
porubcan wrote: new one in .110 - mood preview is missing in main menu "My Waze" icon.
Actually the mood preview is there, it just replaced the old "My Waze" icon by the "My Mood".
2012-10-01 15.26.12.jpg
(136.69 KiB) Downloaded 1686 times
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by pvaladares
BUGS
1 - After setting "Go invisible" and "Share my ride: Using an Email" Waze crashed. Waze prompted to send logs, logs sent.
2 - The second time I tried the "Share my ride" worked fine. I sent to my friend and it was possible to track my position in the map. After sometime my 3G connection got some problem and the web link showed this even after I reconnected the 3G (Waze was always running however sometimes in background while I was checking other apps)
waze.jpg
(34.82 KiB) Downloaded 2015 times
Maybe this is why:
Pickup session might end if waze is sent to background
3 - I sent "Pick Up" request for myself and confirmed the Pick Up location via link provided. However I could not receive any location for Pick Up in Waze app.
4 - The link (http://waze.to/xxxxxx) mention in the messages (via email) "Send a location: My current location|My saved location|Recent search" do not work.
To drive here with Waze, open this link from your mobile.
EDIT: Actually the quote says "your mobile", so it correct. You just can't use the link under PC.

SUGGESTIONS
1 - It would be nice to document the new features or create some video explaining what the yellow buttons mean. Not difficult to figure out, but I was surprised seeing them for the first time.
2012-10-01 19.02.34.jpg
(155.66 KiB) Downloaded 2050 times
2 - They way the Share link is created, may be vulnerable to manipulation, for example, the "nickname" string

Code: Select all

http://mobile-web.world.waze.com/social/share_location
?nickname=People may leave here some interesting messages
&token=A token for each session?
&mood=Can be changed? I saw no effect changing this
&frequency=Value in ms?
&lang=What are the current available languages?
3 - I noticed the "Pick Up" feature is requesting the Web-Browser location. Why don't you use this feature also in the WME ?
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times
Last edited by pvaladares on Thu Oct 04, 2012 12:22 am, edited 1 time in total.

Post by pvaladares
When I select a wazer in the map I get two options: 'Map chat' and 'Message'.
I used Message to send some text to other user privately. However I could not find any Inbox menu and messafe showed up as a report, like Map chat does.

Was it really sent privatly to user? Or is a bug and it behaved lika a Map chat?

Sent from my LT18i using Tapatalk 2
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by pvaladares
Autourdupc wrote:
perlin wrote:
porubcan wrote:It is possible to "Share my ride" even I'm not navigating anywhere (menu->meet up->share my ride).
I've tried it and it sent email with link to my current location. Is that setup correct? if yes, maybe it should be called somehow else to avoid confusion.
Yes, it's correct. This is how you can share your location to someone who doesn't have waze (requires only a browser).
Hi Perlin.
I use to test the share my location.
With gmail used to send the mail, I received the link...
Here it is : http://waze.to/hu05knrdmx
If I put it into IE or Chrome, nothing appends !
I found out the link only work under a device where Waze is already installed.
So In Chrome it won't run at all...
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by pvaladares
xteejx wrote:The route preview still fails to show events along the route.


Sent from my GT-I9100P using Tapatalk 2
Route preview is, in my opinion, a major feature that Waze should really implement.


Sent from my LT18i using Tapatalk 2
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by pvaladares
There is another bug: the "My Waze" button is not actually displaying the "Sword", "Shield" or "Crown" (if you have the correct rank - my case)

http://world.waze.com/forum/download/file.php?id=5294
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by pvaladares
I found more bugs:

1 - The First one is related to another bug report in my previous post
3 - If the Settings|General|Events Radius option is changed and thehard button "back" is used the Main Menu will still show the old Events Radius - Waze should force the Menu to refresh (if any option is changed). However if the user use the "X" to close the window then this problem does not occur.
This is bug is related with the My Mood and Go Invisible feature.
After enable "Go Invisible" if you go back with the soft key "go back" the Main Menu button will not update to the invisible mood.
This problem does not occur if the user go back with the "X" button.

Here is the sequence:

1.1 Access the Main Menu
http://i45.tinypic.com/2ivo2er.jpg

1.2 Enable "Go Invisible" feature. Now the user may go back (cenario 1) with the "Go back" soft button or (cenario 2) with the "X" button
http://i46.tinypic.com/2epitg1.jpg

1.3 Cenario 1 (bug reported) and Cenario 2 (works ok)
http://i50.tinypic.com/20tq7vo.jpg http://i48.tinypic.com/15d2tqq.jpg


2 - Second bug, is about "My Waze|Nickname" in offline mode.
The problem is if user start Waze application without any Internet connection (WiFi or 3G) and access the Nickname option under My Waze. Then, even without editing anything, if the user try to exit this menu (still with no Internet connection) a error message will keep constantly popping up so really no other action can be done under Waze...


http://i47.tinypic.com/2hyavs9.jpg http://i45.tinypic.com/snfp6s.jpg http://i46.tinypic.com/314w6s4.jpg
pvaladares
Map Editor - Level 5
Map Editor - Level 5
Posts: 957
Has thanked: 75 times
Been thanked: 160 times

Post by porubcan
seems that it has to be reported more than just couple of times to get devs to fix it... i was reporting the same already for 3.2 beta in June... http://world.waze.com/forum/viewtopic.p ... +p#p191989
porubcan
Waze Global Champs
Waze Global Champs
Posts: 6416
Has thanked: 619 times
Been thanked: 1810 times

Post by porubcan
I noticed scoreboard design change. As It's web it is not related only to beta. Few comments:

Top 3 wazers are part of the list, not separate small table. Wondering what will happen after points update.

What is wrong on showing country/state in scoreboard? It is not there now.

Some graphical glitches - friends with long names - whole names are not displayed even there are 2 lines reserved in particular row.

EDIT: with this scoreboard change I noticed that previously reported "some friends are missing in friends tab of scoreboard" gets fixed and now I see all friends both in scoreboard and My Friends menu.
Also my friend who is new user and haven't seen any of his friends in the scoreboard now reported it is working fine.

EDIT2: before myself was listed within fiends tab in scoreboard, now is not.

if it looks strange, it's my phone's fault
porubcan
Waze Global Champs
Waze Global Champs
Posts: 6416
Has thanked: 619 times
Been thanked: 1810 times
Last edited by porubcan on Thu Oct 18, 2012 10:13 am, edited 1 time in total.