[Script] UROverview Plus v3.112 (20170914)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] UROverview Plus v3.100 (20170311)

Postby Twister-UK » Mon Mar 13, 2017 6:12 pm

Doh, that's what happens when you improve the way your code detects which object is being hovered over, but then fail to realise just how many different places within your code reference the ID of that object and therefore require updating in order to use the new hover-detection results... I'll fix this tonight.
Twister-UK
Beta tester
Beta tester
 
Posts: 2748
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 410 times
Been thanked: 2422 times

Re: [Script] UROverview Plus v3.100 (20170311)

Postby PesachZ » Mon Mar 13, 2017 5:30 pm

Hey the link in the pop-up to open a UR in a new window shows the ur parameter as null instead of the UR ID.
PesachZ
Wiki Master
Wiki Master
 
Posts: 4447
Joined: Mon Jul 01, 2013 12:51 am
Location: NY, USA (also NJ sometimes) {GC} {ARC}
Has thanked: 1993 times
Been thanked: 2270 times

Re: [Script] UROverview Plus v3.100 (20170311)

Postby Twister-UK » Sat Mar 11, 2017 12:53 am

3.100 makes a few changes to improve stability and provide countermeasures against unexpected DOM changes after the script has initialised...


Firefox+Greasemonkey version: https://greasyfork.org/scripts/1952-uroverview-plus-uro
Chrome Web Store version: https://chrome.google.com/webstore/deta ... mjcdghdphi
Twister-UK
Beta tester
Beta tester
 
Posts: 2748
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 410 times
Been thanked: 2422 times

Re: [Script] UROverview Plus v3.10 (20140614)

Postby bz2012 » Sat Jun 21, 2014 3:02 pm

The problem SEEMS to have gone away on its own! Very strange.

URO+ seems to break WME today.
1) very slow loading of roads
2) left info bar with no data after roads finish loading.
(name etc. 'disappear' after roads finish loading)

Disabling URO+ speeds up loading and the info on the bar does not go away.

Removed and reinstalled; no joy.
Tried disabling ALL other extensions except URO+; no joy.

The info bar did get populated AFTER I selected a road segment.
bz2012
Map Raider
Map Raider
 
Posts: 1497
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 1309 times
Been thanked: 280 times

Re: [Script] UROverview Plus v3.10 (20140614)

Postby yaacobyy » Tue Jun 17, 2014 7:45 am

Thanks for the 2 replies.
yaacobyy
Waze Global Champs
Waze Global Champs
 
Posts: 4930
Joined: Fri Mar 30, 2012 12:00 pm
Location: קריית מוצקין, ישראל
Has thanked: 323 times
Been thanked: 1082 times

Re: [Script] UROverview Plus v3.1 (20131128)

Postby beersh » Thu Dec 05, 2013 8:53 pm

shawndoc wrote:The hide function not working on UR's, and possibly MPs in the current beta editor. Works fine in the regular editor.

Someone suggested disabling Toolbox, which I did, but its still not hiding UR's and MPs I've told it to. Hover is working though. Seems to be affecting at least some of the other beta editors as well.

+1
beersh
 
Posts: 5987
Joined: Thu Mar 13, 2008 2:39 pm
Location: Israel
Has thanked: 224 times
Been thanked: 175 times

Re: [Script] UROverview Plus v3.1 (20131128)

Postby HandofMadness » Thu Dec 05, 2013 8:03 pm

I guess I should add:
URO+ 3.1
Chrome 31.0.1650.63 m
HandofMadness
Area Manager
Area Manager
 
Posts: 1802
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 375 times

Re: [Script] UROverview Plus v3.1 (20131128)

Postby HandofMadness » Thu Dec 05, 2013 8:01 pm

The hide function not working on UR's, and possibly MPs in the current beta editor. Works fine in the regular editor.

Someone suggested disabling Toolbox, which I did, but its still not hiding UR's and MPs I've told it to. Hover is working though. Seems to be affecting at least some of the other beta editors as well.
HandofMadness
Area Manager
Area Manager
 
Posts: 1802
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 375 times

Re: [Script] UROverview Plus v3.1 (20131128)

Postby Twister-UK » Wed Dec 04, 2013 7:35 am

*sigh* it never ceases to amaze me just how many different ways the Waze coding team manage to find to implement the same outward functionality with every WME refresh... I've just had a similar bug report from another user, so I'll look into it when I get some free time - probably next week at the earliest.
Twister-UK
Beta tester
Beta tester
 
Posts: 2748
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 410 times
Been thanked: 2422 times

Re: [Script] UROverview Plus v3.1 (20131128)

Postby paulkok_my » Wed Dec 04, 2013 3:03 am

I'm not sure whether any of you guys are facing this but it seems the filter to not show approved cams is not working for the beta editor. On the public editor I do not face any problems.

On the beta editor, the approved cams is still appearing even though I ticked not to show.
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1153
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 327 times
Been thanked: 245 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: JustinS83, Kayos_On_The_Road, mkurniawan, Mythdraug, pironic, ramblinwreck_81