[Script] Highlights for Segments & Landmarks - v1.5 Nov 16

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderator: Unholy

Re: [Script] Highlights for Segments & Landmarks - v1.5 Nov

Postby shawndoc » Fri Jan 25, 2013 3:18 am

iainhouse is correct, what you see there is Waze routing the user to the end of a dead end and then turning them around and back out. Since Waze doesn't officially support U-Turns, that's one of the methods its uses to turn someone around if there's no easy around the block or left followed by a left in the vicinity.
Image
shawndoc
Area Manager
Area Manager
 
Posts: 1702
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 16 times
Been thanked: 342 times

Re: [Script] Highlights for Segments & Landmarks - v1.5 Nov

Postby skapur1 » Sun Feb 10, 2013 2:55 am

CrackedLCD wrote:
Timbones wrote:And it's not even specific to the JNF script - any editor can use QW on every junction node they see with red arrows, blindly allowing all turns without adding value to the map and destroying any information that may have been there.

Displaying 'measles' to every road just presented another excuse to 'fix' junctions that didn't need fixing.


This line of thinking may be appropriate for where you live, but in my part of the US, minor roads on Waze are often very heavily travelled despite not qualifying for primary or minor/major highway status. And in suburban areas, we don't have one way streets or, for that matter, much in the way of turn restrictions, so blindly allowing turns and fixing revcons are actually not that harmful for 99% of the area that I cover.


I agree but only for residential areas.

In rural and suburban US residential areas one way streets and turn restrictions are extremely rare. They are other mapping sources/satellite images that can be scanned to see if there are any such turn restrictions or one way streets in an area and if there are none, but every intersection in Waze has them, then Waze is grossly incorrect and may need some "blind" correction.

It is better to remove them to improve routing for 99% of the routes then to leave them be so that only 1% of the routes are correct. A driver who should always obey posted signs and not follow Waze blindly.

In suburban and rural US one way roads or turn restrictions are usually for parking lots, drive thrus, split roads and private roads leading to building entrances (e.g. schools, hotels, office buildinngs, shopping malls etc.).

Urban areas and even rural towns are completely different and do have many one way roads and loads of turn restrictions. This is one of the reasons a lot of people like to live in the 'burbs.
Image
skapur1
 
Posts: 81
Joined: Sat Oct 06, 2012 2:08 pm
Has thanked: 16 times
Been thanked: 6 times

Suggestion to clarify 'Filter by City' selection

Postby skbun » Mon Oct 22, 2012 7:42 am

Hi all. Please consider the following Permalink for an example:

https://www.waze.com/editor/?zoom=5&lat ... TTTFTTTTFT

You will notice, if using WME Colour Highlights 1.3 in this location, that you will see TWO 'Federal Way's. The behind the scenes reason for this isn't important, but it does illustrate a problem that can make this selection tool a little difficult to use.

The real reason you see two of this identical city is because there's an (erroneous but present) other state incorrectly entered in a node near here.

Therefore, I'd like to propose for situations like this that the 'GetCity' filter dropdown display like this, when listing nearby cities:

Current:
Federal Way
Federal Way
Lakeland North
Washington

Proposed:
Federal Way, Alabama, United States
Federal Way, Washington, United States
Lakeland North, Washington, United States
(No City), Washington, United States

I know from trial and error that the 'Current' list actually means the proposed list, but it's kind of a pain to figure that out by trial and error. So I guess what I'm asking is, can

function updateCityList()

be made a little smarter on the display side, so that it can display more complete listing (thus better meaning) while identifying problems?

(I am aware that there's a beta for this tool that I don't have access to, so I don't know if this has already been discussed there!)
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: Script to add Highlights for Segments & Landmarks - v1.4

Postby skbun » Wed Oct 31, 2012 5:45 am

Timbones wrote:Okay, I really think I've got it now. Tested in Firefox, Chrome and Tampermonkey.

v1.4.2 - http://userscripts.org/scripts/show/141050


This is a fantastic tool, thank you! I've spent time now cleaning up reverse connectivity and u-turns. I wonder, as a question of a future feature...is it possible to do a quicker 'scan' of visible segments, like we do for 'recently edited', or 'author', or whatnot, where 'If at least one bad node is seen in a segment, the node or segment is highlighted in a color'?

We don't need to know that any given segment has '25 reverse connectivity instances', for a sweep like that, but only that 'there is at least one'. I have a feeling a scan like this might murder the script or the editing server, but oh BOY would it save time identifying and squashing these problems!

(Of course, we can still keep the particular highlighting for one you do one single segment, to fix the actual segments one at a time! But this makes them easier to find first, if possible to do.)
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: [Script] Highlights for Segments & Landmarks - v1.4.2 Oc

Postby skbun » Thu Nov 01, 2012 12:41 am

I'm seeing an interesting bug that seems pretty predictable to reproduce. It's in the 'Average speed for segment' section dealing with nodes, and it looks like this:

If I touch any given segment, and then click 'Save' in WME, any segment which I had changed comes up with a wacky speed result. It doesn't matter whether I have any node (or the node in question) highlighted when I do click save; this result persists until I reload the page.

Before saving:
Average speed for segment
A->B: 96km/h (59.7mph)
B->A: 114km/h (70.8mph)
Average speed for segment
A->B: 9684km/h (6017.4mph)
B->A: 11449km/h (7114.1mph)

I can return sanity to the 'average speed' by reloading the editor in my browser.

Whatever is going on here, it seems to be an issue that 'WME Extended Tools' shares, in its 'Segment list', when Fwd and Rev speed are shown as columns.

I also recognize that this could be a problem with the server backend giving an oddball result, which it to say that we can't do anything about it. Thought I'd mention it, anyway.
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: [Script] Highlights for Segments & Landmarks - v1.4.2 Oc

Postby skbun » Thu Nov 01, 2012 9:39 pm

Timbones wrote:
skbun wrote:If I touch any given segment, and then click 'Save' in WME, any segment which I had changed comes up with a wacky speed result. It doesn't matter whether I have any node (or the node in question) highlighted when I do click save; this result persists until I reload the page.

This is a known bug in the WME code, for which I may include a fix for in future versions.
Workaround for now is to reload the editor, or ignore the crazy speeds.


Sure-sure. I thought it might be, since I couldn't see anything in the .js code that would explain why pulling fwdspeed and revspeed would suddenly be multipled as it is, but this is good to hear from the horse's mouth. Thank you very much! :)
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: [Script] Highlights for Segments & Landmarks - v1.4.2 Oc

Postby skbun » Thu Nov 01, 2012 9:46 pm

Timbones wrote:
TheDane wrote:+1 on the suggestion from skbun about making it possible to see all problems in an area using a colour coding for all segments that have issues.

This was how it worked in an earlier version but it showed an aweful lot of problems, most of which don't actually need fixing. I felt that showing all nodes with soft-turns would encourage editors to QW all of them, which adds little value to the map and increases the chance of turns being set incorrectly. Therefore, I took the decision to only show them for one node/segment at a time, for when a particular routing issue needs to be diagnosed.


Hmm. So I'm on the same page with you in the sense that soft turn junctions aren't really a big problem. When I'm scanning and fixing nodes, the ones I'm REALLY looking for are 'violets' and 'reds', reverse connectivity and U-turns, because I find that they DO mess up routing, and also can cause issues trying to connect roads together in the editor, because nodes won't snap in properly. It's probably great and all that soft turns are highlighted on a segment by segment basis, but what about flagging the two 'severe' ones in the global highlight way described?

So, highlight all roads: U-turns, reverse connectivity.
Highlight in any one selected segment: soft turns, U-turns, reverse connectivity.

I don't care much about yellows either. But the others, yeah.

U-turns I generally have to move the segment with the U-turn away from the junction, Q, move it back in, W. Reverse connectivity, depending on how deep and ugly the issue, could just be highlighting the offending near segment and QW-ing, or moving the offending segment node to a dummy road (or other endpoint) to 'destroy the node', and reconnect.
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: [Script] Highlights for Segments & Landmarks - v1.4.2 Oc

Postby skbun » Sat Nov 03, 2012 5:47 pm

TheDane wrote:In Copenhagen I tried fixing a UR with a weird routing - and it turned out the segment had 8 (eight!!!) reverse connections and 2 u-turns (its a 167 m long segment) and also many of the neighboor segments had similar issues (maybe only 3- 6 reverse connections). I have not even looked at the soft turns - I agree they are way less important (at least initially).

I have highlighted two example sections in the link if anyone cares to have a look :-) The area is not fixed yet - simply gone on the To Do list...


Poking segment by segment around the greater Seattle area, I think my record for 'most reverse connections on a segment' was about 44, with several in that immediate area having 25+. I saw that and just had to laugh out loud. Before fixing it, that is!

As you say. The problem U-turns and reverse conns are out there. :lol: Those are the only two I'd want globally highlighted anyway. Soft turns aren't actually a problem worth proactively fixing, nor seeing globally! (But it's useful on single segment highligting, IMHO.)
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: [Script] Highlights for Segments & Landmarks - v1.4.2 Oc

Postby skbun » Sun Nov 04, 2012 7:43 am

mike-bronner wrote:I know .... That's what I find it quite irksome that they don't address this. I have reported this issue since I started editing, probably over a year ago.
I have come up with a patch for Tim's script that will allow highlighting of states, and have been using it this evening quite successfully, so the good news is hat it's definitely doable. I have submitted it to Tim in the hopes that he might include it in the next release. :)


Heh! That's awesome. I was poking around the code a bit myself. That Tim doesn't have a state field where he is explains a behavior we see in North America. (I hacked on the 'get city names' script a little)...

I find myself wishing that the city pulldowns also had the state (if it exists), and Waze's internal ID alongside. One, it makes 'the right city in this area' obvious when there are several with the same name, and two, because I wonder if they could be used somehow to find and identify segments that cause city smudges. (See http://www.waze.com/wiki/index.php/Fixing_%22smudged%22_cities ).

This would -especially- be true if you can set one city as persistent, and be allowed to zoom out and just say 'Is this blah blah city ID anywhere in this range?'

If you consider the permalink https://www.waze.com/editor/?zoom=3&lat ... TTTFTTTTFT

...and modify the highlights script to dump out City IDs to the console.log, you get something like this:
Auburn 23489
Pacific 23491
Tacoma 23509
Algona 23597
Federal Way 23608
Federal Way 23877
Lakeland South 23878
Federal Way 50088
Federal Way 51273
(NULL?) id:999953
* Washington 100000040

* That last one is the correct state.

Of course, without the IDs, you see four 'Federal Way's, all shown as the same city. This said, I'm pretty sure three of the four have different incorrect states behind them: Alabama, and Oregon. All evidence of a city smudge, but not the ID number that might help trace it. (How to USE said ID I'm not sure yet. Anyone have any ideas?)
Last edited by skbun on Sun Nov 04, 2012 12:47 pm, edited 1 time in total.
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

Re: [Script] Highlights for Segments & Landmarks - v1.4.2 Oc

Postby skbun » Sun Nov 04, 2012 7:50 pm

Timbones wrote:I have made a beta version that appends the state and/or country when there are more than 1 defined in the model. It works quite will with skbun's example of Federal Way above. I've also tested it on international server.

> WME Colour Highlights Beta - v1.4.3

Let me know if this works for you guys...

PS: I also notice that each state object has a geometry. Any ideas what we can do with it?


Tim,

What should I be seeing in the dropdown?

I see:
Algona
Auburn
Federal Way
Federal Way
Federal Way
Lakeland North
Lakeland South
Washington

...so I don't think that I'm seeing 'the right thing', perhaps? Granted, I'm on the current WME, not the beta, if that matters. :)
Image

AM in SW Shasta, NW Tehama, Central Trinity Counties, CA; Mt Rainier Nat'l Park, WA
skbun
US Waze Champs
US Waze Champs
 
Posts: 424
Joined: Sun May 06, 2012 12:27 am
Location: Seattle/Tacoma WA
Has thanked: 27 times
Been thanked: 46 times

PreviousNext

Return to Waze Map Editor

Who is online

Users browsing this forum: mikupoiss