Map Editor major ver (Nov 5, 2012) Official Feedback

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderators: Unholy, bextein

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Dec 04, 2012 10:26 am

I think I found out yet another issue, albeit I think this was also happening on the previous editor. This seems to be the reason for my reversed A-B -> B->A roundabout and other segments.

- Create a segment from left to right, A->B
- Create a second segment connected to B, also left to right
- You'll have two connected segments A->B A->B
- click on the node
- press delete
- alternatively click on both segments, whichever order, and click on the bridge

what would happen
- one segment with A->B

what happens
- randomly the segment becomes B->A. Funny thing is that 90% of the time, doing "undo" and repeating the exact same operation (delete node or bridge) will do the correct thing and keep the new segment A->B

Now I understand why I have so many segments with one-way and locked but with fwd and rev average speed. It was my adjustments of ramps or roundabout nodes that were reversing the A->B to B->A and screwing the up.

Now it's way easier to identify with the big A and B balls. Again, if fails, undo and repeat!
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Thu Nov 29, 2012 4:30 pm

AlanOfTheBerg wrote:
davipt wrote:Edit: false alarm, could only save two edits :(

The intl editor was offline for a while. Is it back up?


Yep working perfectly
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Thu Nov 29, 2012 11:31 am

lakj100 wrote:
davipt wrote:Just a heads up that for me the INTL editor is not saving any editing at all. No errors, just no changes apply. :| time for a break


I'm also having the problem.


I think it's back :)

Edit: false alarm, could only save two edits :(
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Thu Nov 29, 2012 11:18 am

Just a heads up that for me the INTL editor is not saving any editing at all. No errors, just no changes apply. :| time for a break
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Nov 27, 2012 4:06 pm

PhantomSoul wrote:Is anyone with Safari 6 and Mac OS 10.8 (Mountain Lion) having any trouble getting the permalinks to capture selected road segments? Last night while requesting some unlocks to resolve various UR's in my area, I noticed some inconsistent behavior with it, in that it sometimes included the selections and other times didn't.


Do you have any extensions? For example I hardly get the segments selected when using the highlights extension, have to look at the code to understand why ;)
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Nov 20, 2012 6:57 pm

daknife wrote:Often the only solution for such a loop is to delete it as one piece, save your changes and then redraw. It's one reason such loops are such a big pain is that once created in the system, you can't edit them, you can only delete them.


There was already on this thread a second solution for that:
- create a new segment connected to that loop, with the exact same street and city
- click on both segments and bridge them
- now you can edit the loop :D
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Nov 20, 2012 12:44 am

jasonh300 wrote:The thing with the geometry node sticking to the mouse pointer has been around for a while, but now, you can click multiple times and it still won't let go. It also seems to do it a lot more frequently under certain circumstances, and it does seem to have something to do with rapidly trying to select multiple segments. I found that hitting Escape will get rid of it sometimes, and sometimes it will do it on its own. This is an extremely frustrating bug.


Indeed, that's why I gave my example of the fupped road that I only noticed because there was a user report about that nice highway 90º based detour through the forest :D
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Nov 20, 2012 12:30 am

CrackedLCD wrote:First, when selecting small segments with geometry nodes in between the A-B points, I'm noticing a big tendency for the cursor to not change from the crosshairs back to a pointer. When this happens, if I click anywhere on the screen, it places the geometry node at that spot.


I've seen this happening with my Firefox and Safari and I even have a road live right now that, edited (screwed) with the old editor, a road that does a 90º angle to the side and then a 90º back, with that broken node almost a km away from the real road position. I always thought it was a question of sensitivity from the mouse. Maybe it's really a timing issue.

CrackedLCD wrote:Second, I'm having occasional trouble inputting data like street names onto segments. I'll start typing and then it's like someone hit the escape key, cancelling the operation


This used to happen when the backend is slow and the roads are still loading. Check if the "loading road" is still showing on the right side when you try to edit and if the editing fields goes away at the same time as the "loading road". I haven't seen yet this one on the new editor mainly because I'm more careful now but it did happen a lot before I knew about this, and hence it did happen to me before on the old editor.
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Fri Nov 16, 2012 11:42 am

zs2cli wrote:Maybe already mentioned in the numerous posts above, too many to read, but incase it's not, the new editor does not work in Firefox. :(


I hate when people say this, but I couldn't resist: "it works perfectly for me (*)"

Now more seriously, do you use any additional scripts? the ext tools breaks it. the highlists is safe.

(*) besides the "hard-to-select-horizontal-segments-old-browser-bug"
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Thu Nov 15, 2012 8:55 pm

I'm sorry for reporting this here but I can't find an existing thread or even the right forum for reporting issues on the remaining site not the editor. Please kick me out with a link if you which ;)

I have a certain guy I have unfriended on Facebook some weeks ago. On my dashboard on the world.waze.com/dashboard/scoreboard/ link I still see his score, but at the top of the list with position 0 and name "deleted". On the client (3.5.1) he doesn't appear, but there's a big mess over there I'll be reporting in a minute on the right thread.

Any idea how to solve this, or where to report (besides the support email?)
Bruno D. Rodrigues | Global Champ & Coordinator for Portugal | iPhone Beta
Forum PT | Wiki PT | Facebook PT | Twitter PT
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 5150
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 288 times
Been thanked: 611 times

PreviousNext

Return to Waze Map Editor

Who is online

Users browsing this forum: Yahoo [Bot]