New Android Beta Version - 1.8.99.106

Important messages to community users. This forum is locked (waze staff only).

Moderator: Unholy

Re: New Android Beta Version - 1.8.99.103

Postby schwartzmonkey » Fri Jun 04, 2010 5:12 am

How do we get new version, i show no update yet :(
schwartzmonkey
 
Posts: 1
Joined: Sat Jan 09, 2010 4:48 am
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby grebble » Thu Jun 03, 2010 2:02 pm

After several days of sudden crashes and force closes, today was a better day. Not sure if it's related, but I applied a firmware update to my phone last night, and this morning, everything worked without a hitch. I have, however, discovered another minor bug: if I look at the alternative routes when the auto-navigation comes up, the distances are shown with 'mi' afterwards but are actually in kilometres. So my alternative routes to work show as 32 miles when they're actually about 20 miles, or 32km.

EDIT: I spoke too soon. On the way home tonight, another complete crash, and on the second try, it froze for five minutes before recovering itself. I can't be doing with pulling the battery every day and trying to recover from force closes on my commute, so I'm going back down to v1.7 until this is fixed.
grebble
 
Posts: 136
Joined: Thu Mar 04, 2010 12:20 pm
Location: East Northants, UK
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.103

Postby tskramp » Wed Jun 02, 2010 11:39 pm

Great update, I like the UI changes. The directions looks much better imo. I have not noticed any new problems. The only thing is that I still (and have not been able to for a long time) cannot report a problem as a missing road. When I select it and press send it does not do anything other than highlight green while holding it. Once I switch to any others such as general map problem, then it sends immediately. Thanks for the great work!
tskramp
 
Posts: 50
Joined: Wed Mar 24, 2010 3:51 am
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby Alty » Wed Jun 02, 2010 11:17 am

grebble wrote:So I'm not too happy with the app this morning. It's the first one to completely crash my phone :cry:


I think you've been quite lucky in that respect, I used to get countless force closes and complete crashes (taking the battery out being the only way to fix it; I'm just glad I can take the battery out unlike my old iPhone [not that I wazed on my iPhone])
Alty
 
Posts: 11
Joined: Sat Dec 19, 2009 9:54 pm
Location: Manchester, UK or Luton, UK
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby grebble » Tue Jun 01, 2010 11:27 am

Well I had a shedload of problems with this version today. It all seemed to start up OK when I left the house, but took a while to connect to the network. I put that down to the fact that I had left Wi-fi switched on, and it took its time to realise it needed to connect to the mobile (2G) network. But once it did, the auto navigation came up to route me to work, and all seemed well.

Then, a mile after leaving home, the whole thing just spontaneously froze completely. For the first time ever, my HTC Desire failed to respond to anything. I waited until I stopped for fuel a few minutes later, but the buttons had no effect, not even the power button. I had to resort to taking the battery out to get the damn thing to respond. That's a thing I was used to having to do on my old Nokia device, but never on Android ;)

When the device powered back up, the display was zoomed right out, it seemed, to world level. I zoomed in and it connected to the network briefly, but soon lost it again, even though I had a good 2G/EDGE signal. It didn't connect again until I got into a 3G area, some 15 miles further on.

So I'm not too happy with the app this morning. It's the first one to completely crash my phone :cry:
grebble
 
Posts: 136
Joined: Thu Mar 04, 2010 12:20 pm
Location: East Northants, UK
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.103

Postby Alty » Tue Jun 01, 2010 10:05 am

Somehow, this beta version has completely broken for me.

For some reason, it seems all network functions have broken.

Phone: Motorola Milestone, Android 2.1
Country: UK
Waze: 1.8.99.103

It worked really well initially, then suddenly I fired it up and it said "initializing..." which is fine, but then it says something like "no network" regardless of whether I'm on HSDPA or Wifi, attempted to Send Logs, but naturally as Waze thought there was no net connection, it couldn't send the logs either.

Rather stupidly, I forgot to copy the logs over before attempting to reinstall Waze to rectify the problem as far as I can tell, anyway, since the "debug" folder that was there before has now disappeared and waze_log.txt starts on June 1st.

As an aside point, I think the SD card may have been damaged (forgot to unmount it from the computer one time a couple of weeks ago [Android just now has decided to report it as 'damaged', have attempted to run fsck but that's not fixing the error]) but given timeframes I doubt that this could have caused my waze issue?

Apologies for not having logs, but I hope that I've provided *some* information.

Edit: Have formatted and fixed my SD card, reinstalled Waze having wiped all settings/logs. Will report if it happens again.
Alty
 
Posts: 11
Joined: Sat Dec 19, 2009 9:54 pm
Location: Manchester, UK or Luton, UK
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby MarcoPon » Sat May 29, 2010 11:23 am

Same here: crash assured after confirming a street update.
MarcoPon
 
Posts: 19
Joined: Tue Mar 16, 2010 11:51 am
Location: Martellago (VE) - Italy
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby BalsbyMange » Fri May 28, 2010 11:12 am

I have the same on my waze, always crashing after editing a road and then clicking ok

Sent from my Hero using Tapatalk
BalsbyMange
 
Posts: 256
Joined: Thu Jan 14, 2010 1:19 pm
Location: Kristianstad - Sweden
Has thanked: 0 time
Been thanked: 2 times

Re: New Android Beta Version - 1.8.99.103

Postby khaytsus » Thu May 27, 2010 11:13 am

gerben wrote:Crash on exit and battery drainage are also fixed in the new update!

Editing street properties does not work, the app crashes after pressing the confirm button.

Hadn't noticed any battery issues, but same here, exit is clean now with this version. :)
khaytsus
 
Posts: 863
Joined: Tue Nov 03, 2009 10:43 pm
Location: Lexington, KY
Has thanked: 43 times
Been thanked: 84 times

Re: New Android Beta Version - 1.8.99.103

Postby shalafi » Thu May 27, 2010 8:34 am

The Fej wrote:An alternative way to edit a road is by pressing it and choosing the properties option in the screen that opens. That enables to update the street name.


Clicking OK in that properties screen you mention always crashes waze, regardless of whether I enter anything in the fields or not.
shalafi
Beta tester
Beta tester
 
Posts: 1772
Joined: Wed Nov 25, 2009 2:08 pm
Location: Bratislava / Levice, Slovakia
Has thanked: 268 times
Been thanked: 207 times

PreviousNext

Return to Official announcements

Who is online

Users browsing this forum: No registered users