iOS 3.5.1 official feedback thread

These forums are specific to the Waze mobile app. Post here if you experienced a problem while using the app, have a question about the app functionality or a feature such as navigation or search.

Moderators: Unholy, bextein

Re: iOS 3.5.1 official feedback thread

Postby davipt » Thu Dec 13, 2012 12:15 am

AlanOfTheBerg wrote:When Waze cannot contact the server to get the TTS instructions, it falls back to pre-recorded announcements. I've seen some posts from people who have received instructions in other languages, too.


The client can't play sentences that haven't been actively selected and downloaded, so the question is what is the language that is used as a fallback when there is no internet for the TTS - the last selected one? the default one for the country? a random one? the first on the downloaded folder list? What I mean is that the client surely won't start speaking Spanish if the user never picked up Spanish as the voice language ;)
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 2770
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 284 times
Been thanked: 596 times

Re: iOS 3.5.1 official feedback thread

Postby AlanOfTheBerg » Wed Dec 12, 2012 8:48 pm

When Waze cannot contact the server to get the TTS instructions, it falls back to pre-recorded announcements. I've seen some posts from people who have received instructions in other languages, too.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23613
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4791 times

Re: iOS 3.5.1 official feedback thread

Postby calli84 » Wed Dec 12, 2012 8:11 pm

Good evening dear Wazers

Maybe it's only a problem on my Iphone but today in the morning as I drove to my office the announcement switched completly to the minimal version. After a few kilometers the full TTT was availible. But before this I had never changed this in option menu.

Is there a bug in the iOS version?

And as I wanted to drive back home the TTT announcement had a nice and funny vocabulary. If you reach the destination the Waze-assistent (in Germany it's called "Steffi" for the female voice) says "you arriving you destination" ... in the German way of speech. :lol:

Since today if you reach the 200 meter before the turn or something else the assistent say "in two hundred meter biegen Sie links in die blablabla Straße ab" (also "in 200 m turn left into street blablabla").

How is it in the other languages? Or do I have a problem with my mobile phone?

Greetings
Calli

(sorry for my bad English)
calli84
 
Posts: 37
Joined: Mon Feb 13, 2012 1:51 pm
Has thanked: 0 time
Been thanked: 1 time

Re: iOS 3.5.1 official feedback thread

Postby AggieJM » Wed Dec 12, 2012 3:01 pm

One other item I noticed was that the "cookie eating" behavior was a little erratic.

I was in an area on Saturday night that had quite a few unmunched roads, so I drove a few of them because I needed some details to make map updates. I noticed that when I would reach a section where the cookies displayed, the icon on the map wouldn't change and the cookies would stay behind. After I had driven a short distance, then it would start munching and quickly stop and show that I posted 1 point. On some really long sections, it would restart and go for a way, but it would stop again before I reached the end of the section.

I'll try to recreate this in my local area on debug mode, but I'll have to find some roads with cookies left on them.
AggieJM
Area Manager
Area Manager
 
Posts: 181
Joined: Mon Sep 26, 2011 10:15 pm
Location: Celina, Texas, USA
Has thanked: 5 times
Been thanked: 2 times

Re: iOS 3.5.1 official feedback thread

Postby AggieJM » Wed Dec 12, 2012 2:40 pm

perlin wrote:
AggieJM wrote:4) I've noticed some odd behavior around the route that is automatically selected. On some longer routes it will select a route that is both longer and slower than the alternates. I posted a topic about this, but didn't get any replies yet. It's not a small difference in some cases. The example I posted the other night was a difference of 30 miles and 30 minutes.

Link to the relevant post?


My mistake, I was posting from my phone last night and forgot the link.

viewtopic.php?f=6&t=34096

I'll get the logs and screenshots for the other items as soon as I can recreate them.
AggieJM
Area Manager
Area Manager
 
Posts: 181
Joined: Mon Sep 26, 2011 10:15 pm
Location: Celina, Texas, USA
Has thanked: 5 times
Been thanked: 2 times

Re: iOS 3.5.1 official feedback thread

Postby perlin » Wed Dec 12, 2012 7:21 am

AggieJM wrote:1) Auto Day/Night switch isn't working. I drove Saturday for a couple of hours after dark and it never switched. I finally had to manually switch to night mode so it would stop blinding me.

Can you send logs that contain such a drive? Please mention the date and approximate hour of the drive, after you send.

AggieJM wrote:2) When I pick a location from favorites, the mileage and/or trip time and randomly way off in the summary screen that appears first. For example, sometimes it will show 5 miles for a trip that is closer to 20 miles. Or it may show a 10 minute ETA for a 30 mile trip. When the actual navigation starts, both the mileage and time are correct.

Please provide a screenshot and logs (if it happens again).

AggieJM wrote:4) I've noticed some odd behavior around the route that is automatically selected. On some longer routes it will select a route that is both longer and slower than the alternates. I posted a topic about this, but didn't get any replies yet. It's not a small difference in some cases. The example I posted the other night was a difference of 30 miles and 30 minutes.

Link to the relevant post?
perlin
 
Posts: 1312
Joined: Thu Sep 16, 2010 8:42 am
Has thanked: 4 times
Been thanked: 74 times

Re: iOS 3.5.1 official feedback thread

Postby davipt » Fri Dec 07, 2012 11:24 am

Here's yet another set of possible issues:

1. on my iOS local waze log files (postmortem) I have the following line, average one per second, but with periods of dozens per second, and periods of one per some seconds, filling up megabytes of disk space:
[11:01:53 Error] (sprite) no image found for small_yellow_arrow [poi.c:534 (poi_display)]

iDavi:2012.12.07.11.03 bruno$ dir
total 16704
-rw-r--r-- 1 bruno staff 6970538 Dec 7 11:03 archive_postmortem
-rw-r--r-- 1 bruno staff 1577536 Dec 7 11:03 postmortem
iDavi:2012.12.07.11.03 bruno$ wc -l *
76206 archive_postmortem
17166 postmortem
93372 total
iDavi:2012.12.07.11.03 bruno$ grep 'no image found for small_yellow_arrow' * | wc -l
90848
iDavi:2012.12.07.11.03 bruno$ grep -v 'no image found for small_yellow_arrow' * | wc -l
2524

2. sometimes I loose the ability of getting the map scrolling with the car. Pressing the icon on the left side to center on my position does nothing, no scroll, no zoom back to my position. Need to restart the app to solve it. Sometimes it even switches to 2D. I can't yet relate if it's when a popup appears or something, but I do have these lines on the logs right before I restarted the client:

[10:22:52 Warning] Canvas module 3D is not ready!!! Can not call OGL functions! [canvas3d.c:347 (canvas3_ogl_updateScale)]
[10:23:31 Error] RemoveAlert() - Failed (List is empty). ID 185691169 not found [RealtimeAlerts.c:1063 (RTAlerts_Remove)]
*** Starting at 07/12/2012 10:23 ***

PS: this may be related to me changing the file "user:Map.Show top bar on tap: yes", which I turned off again, but "user:Map Icons.Show on screen on tap: yes" is correctly working (tap on map shows and hides the center/north/zoom in/zoom out icons correctly)


3. I'm pumping the waze voice instructions via bluetooth to my volkswagen based radio (no music from the iPhone though), and after I receive or make a call, waze stops giving me voice instructions.
I can only see these relevant lines on the logs. between 20:27 and 20:29 there was the voice call.

[20:27:50 Warning] WST::OnHTTPAck() - Succeeded [websvc_trans.c:1106 (OnHTTPAck)]
[20:29:22 Warning] OPENEARSLOGGING: The Audio Session was interrupted. [AudioSessionManager.m:519 (audioSessionInterruptionListener)]
[20:29:44 Warning] Sound play failed 'play' command [sound.m:324 (play_file)]
[20:29:45 Warning] OPENEARSLOGGING: The Audio Session was interrupted. [AudioSessionManager.m:519 (audioSessionInterruptionListener)]
[20:29:48 Warning] Freeing all canvas tiles [canvas_tile.c:1785 (canvas_tile_free_all)]
[20:30:40 Warning] OPENEARSLOGGING: The Audio Session interruption is over. [AudioSessionManager.m:530 (audioSessionInterruptionListener)

I've also sent my logs via client. case 1 happened a lot yesterday between 20h and 21h19 and this morning between 10h and 11h. Case 3 happened yesterday around 20h29 and 20h43.
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 2770
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 284 times
Been thanked: 596 times

Re: iOS 3.5.1 official feedback thread

Postby dlangille » Thu Dec 06, 2012 9:44 pm

dlangille wrote:Tonight I upgraded my phone. Old = iPhone 4. New = iPhone 5

Prior to activating the new phone, I did backed up to both iCloud and to my laptop (via iTunes).

History came over fine. I'm impressed. I didn't expect that. Thanks.

When activating Waze for the first time on the new phone, it asked about favorites. I said yes. I'm not sure if the question was 'restore' or 'copy'. But what I have is an old set of favorites. They are from September or so.

Any suggestions as to how I can get the favorites in the old phone over to the new phone?


Known problem with 'new' install: viewtopic.php?f=7&t=33631&p=308827#p308827
dlangille
 
Posts: 23
Joined: Thu Oct 13, 2011 8:18 pm
Has thanked: 0 time
Been thanked: 0 time

Re: iOS 3.5.1 official feedback thread

Postby AlanOfTheBerg » Thu Dec 06, 2012 3:35 am

jasonh300 wrote:You can turn off the proximity sensor in the voice recognition options.

To be clearererer: turning off voice commands will not stop the blanking, but turning the feature to 3-finger tap only will do it.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23613
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4791 times

Re: iOS 3.5.1 official feedback thread

Postby Ruby799 » Thu Dec 06, 2012 2:43 am

Proximity sensor blanks Waze screen

When I move my hand near the ear piece on my iPhone4 to select an option in that part of the screen or even to just reposition the phone in my hand, the whole Waze screen goes blank. I'm assuming that Waze turns on the proximity sensor for some reason, but it's disconcerting to have the screen go blank all the time.
Ruby799
 
Posts: 37
Joined: Tue Oct 09, 2012 12:03 am
Location: Bay area, California USA
Has thanked: 1 time
Been thanked: 0 time

PreviousNext

Return to Waze App

Who is online

Users browsing this forum: Bing [Bot], Google Feedfetcher, Yahoo [Bot]