New Android Beta Version - 1.8.99.106

Important messages to community users. This forum is locked (waze staff only).

Moderator: Unholy

Re: New Android Beta Version - 1.8.99.103

Postby grebble » Tue Jun 01, 2010 11:27 am

Well I had a shedload of problems with this version today. It all seemed to start up OK when I left the house, but took a while to connect to the network. I put that down to the fact that I had left Wi-fi switched on, and it took its time to realise it needed to connect to the mobile (2G) network. But once it did, the auto navigation came up to route me to work, and all seemed well.

Then, a mile after leaving home, the whole thing just spontaneously froze completely. For the first time ever, my HTC Desire failed to respond to anything. I waited until I stopped for fuel a few minutes later, but the buttons had no effect, not even the power button. I had to resort to taking the battery out to get the damn thing to respond. That's a thing I was used to having to do on my old Nokia device, but never on Android ;)

When the device powered back up, the display was zoomed right out, it seemed, to world level. I zoomed in and it connected to the network briefly, but soon lost it again, even though I had a good 2G/EDGE signal. It didn't connect again until I got into a 3G area, some 15 miles further on.

So I'm not too happy with the app this morning. It's the first one to completely crash my phone :cry:
Area manager: East Northants, West Cambs and Peterborough, UK
Samsung Galaxy Nexus (Android 4.0.4), Waze v3.0.2.8
grebble
 
Posts: 136
Joined: Thu Mar 04, 2010 12:20 pm
Location: East Northants, UK
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.103

Postby Alty » Wed Jun 02, 2010 11:17 am

grebble wrote:So I'm not too happy with the app this morning. It's the first one to completely crash my phone :cry:


I think you've been quite lucky in that respect, I used to get countless force closes and complete crashes (taking the battery out being the only way to fix it; I'm just glad I can take the battery out unlike my old iPhone [not that I wazed on my iPhone])
• phone: motorola milestone - android 2.1 • waze: 1.8.99.103 • car: renault megane •
Alty
 
Posts: 11
Joined: Sat Dec 19, 2009 9:54 pm
Location: Manchester, UK or Luton, UK
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby tskramp » Wed Jun 02, 2010 11:39 pm

Great update, I like the UI changes. The directions looks much better imo. I have not noticed any new problems. The only thing is that I still (and have not been able to for a long time) cannot report a problem as a missing road. When I select it and press send it does not do anything other than highlight green while holding it. Once I switch to any others such as general map problem, then it sends immediately. Thanks for the great work!
Area Manager: Charleston, Mt. Pleasant, West Ashley, Summerville, Hanahan SC
Phone: Nexus One (Froyo)
Waze 1.9.0
tskramp
 
Posts: 50
Joined: Wed Mar 24, 2010 3:51 am
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby grebble » Thu Jun 03, 2010 2:02 pm

After several days of sudden crashes and force closes, today was a better day. Not sure if it's related, but I applied a firmware update to my phone last night, and this morning, everything worked without a hitch. I have, however, discovered another minor bug: if I look at the alternative routes when the auto-navigation comes up, the distances are shown with 'mi' afterwards but are actually in kilometres. So my alternative routes to work show as 32 miles when they're actually about 20 miles, or 32km.

EDIT: I spoke too soon. On the way home tonight, another complete crash, and on the second try, it froze for five minutes before recovering itself. I can't be doing with pulling the battery every day and trying to recover from force closes on my commute, so I'm going back down to v1.7 until this is fixed.
Area manager: East Northants, West Cambs and Peterborough, UK
Samsung Galaxy Nexus (Android 4.0.4), Waze v3.0.2.8
grebble
 
Posts: 136
Joined: Thu Mar 04, 2010 12:20 pm
Location: East Northants, UK
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.103

Postby schwartzmonkey » Fri Jun 04, 2010 5:12 am

How do we get new version, i show no update yet :(
schwartzmonkey
 
Posts: 1
Joined: Sat Jan 09, 2010 4:48 am
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.103

Postby grebble » Fri Jun 04, 2010 8:47 am

schwartzmonkey wrote:How do we get new version, i show no update yet :(


Here (as it's beta it's not in the Android Market yet):

The Fej wrote:Correction version http://tinyurl.com/1899103

Updates and fixes:

* Fonts adjustments
* Roads width adjustments for HD screens
Area manager: East Northants, West Cambs and Peterborough, UK
Samsung Galaxy Nexus (Android 4.0.4), Waze v3.0.2.8
grebble
 
Posts: 136
Joined: Thu Mar 04, 2010 12:20 pm
Location: East Northants, UK
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.104

Postby The Fej » Fri Jun 04, 2010 12:26 pm

The new Android alpha version 1.8.99.104 ( 1.9 pre-release ) can be downloaded from
http://tiny.cc/1899104

Updates and fixes:

* Large log outputs while navigating (which is probably the reason for the freezes and crashes)
* Navigation bar fixes
* Physical keyboard numbers and symbols input
* UI fixes in Data Usage dialogue
* Gracefull exit on shared library failure
The Fej
Waze Management
Waze Management
 
Posts: 1068
Joined: Sun Feb 22, 2009 12:02 pm
Has thanked: 0 time
Been thanked: 40 times

Re: New Android Beta Version - 1.8.99.104

Postby grebble » Fri Jun 04, 2010 2:12 pm

Thanks Fej. I'll give this a go on my way home today.
Area manager: East Northants, West Cambs and Peterborough, UK
Samsung Galaxy Nexus (Android 4.0.4), Waze v3.0.2.8
grebble
 
Posts: 136
Joined: Thu Mar 04, 2010 12:20 pm
Location: East Northants, UK
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.104

Postby shalafi » Fri Jun 04, 2010 2:15 pm

"* Gracefull exit on shared library failure"

oh my, thanks heaps for this. :D and goddamn samsung for screwing that library up .. at least now it doesn't lock my phone up anymore, thanks Waze :)
CM Slovakia
Image
shalafi
Waze Global Champs
Waze Global Champs
 
Posts: 1769
Joined: Wed Nov 25, 2009 2:08 pm
Location: Bratislava / Levice, Slovakia
Has thanked: 268 times
Been thanked: 205 times

Re: New Android Beta Version - 1.8.99.104

Postby Rytis » Sun Jun 06, 2010 9:54 am

Ever since 1.8.99 version Waze has been losing GPS connectivity. Android status shows GPS connected, and GPS icon shows green in Waze, but it starts using cell location instead. This happens very often (probably twice in a 10km run), and the only way I've found to fix is to either restart Waze or disable and reenable GPS in Android, neither of which is a very good solution when driving. Sometimes (very rarely) Waze picks it up again by itself. Android 2.1 (HTC Hero, VanillaDroid 3.0).

[edit] While it may seem that it's a problem with the Android build I'm using, it does not seem to be - Google Maps never loses GPS connectivity.
Phone: Motorola Defy
Car: Ford Focus 2011
Rytis
Localizers
Localizers
 
Posts: 66
Joined: Thu Dec 24, 2009 1:13 pm
Location: Kaunas, Lithuania
Has thanked: 1 time
Been thanked: 1 time

PreviousNext

Return to Official announcements

Who is online

Users browsing this forum: No registered users