iPhone 3.5.3 official feedback thread

These forums are specific to the Waze mobile app. Post here if you experienced a problem while using the app, have a question about the app functionality or a feature such as navigation or search.

Moderator: Unholy

Re: iPhone 3.5.3 official feedback thread

Postby AlanOfTheBerg » Tue Jan 29, 2013 4:33 pm

perlin wrote:
AlanOfTheBerg wrote:BUG: 500ft turn notification happens at 1000ft (reported multiple times in beta testing)

Please send me (debug) logs that contains an example.

Not sure why logs are required. This is reproducable 100% of the time and I explained in detail already that Waze gives the "500ft" notification as soon as the distance to the turn goes from .2 to .1 miles. The problem is not enough significant digits or rounding, because the announcement is made at .19 miles, which is 1000ft feet, not 500ft.

In any case logs uploaded at 4:30PM GMT on 2013-01-29. I noted it specifically at (local times) on 2013-01-28 at 5:59PM, 6:05PM, 6:30PM, 6:31PM. However, as noted, it happens without fail, every single time a .1 miles notification comes up at the .19 mile mark.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 8.2 | Waze v3.9.4
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23307
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1052 times
Been thanked: 4321 times

Re: iPhone 3.5.3 official feedback thread

Postby AlanOfTheBerg » Tue Jan 29, 2013 4:39 pm

This morning I was on my way to work, following one of the normal routes. When stopped at a stop light, I received an "Oh, snap!" message without any interaction with the phone.

ohsnap_why.jpg
ohsnap_why.jpg (53.32 KiB) Viewed 1311 times


Problems here:
1. This is a very large popup
2. Despite being an oversized popup and on an iPhone 5, the text still doesn't fit on the screen due to overuse of whitespace and graphics and buttons too large. (How many years do we need to keep harping on about poor use of screen space?)
3. I don't understand "Info" and "Go there" because there's no indication what this popup is about. Why would I "Go there"?

This looks to be from a popup advertisement which failed to get information. As we've mentioned dozens of times before, Waze needs significantly better error handling and needs to stop assuming that nothing will ever go wrong with other parts of the system. This is an example of a popup which should never have come up on the screen in the first place.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 8.2 | Waze v3.9.4
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23307
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1052 times
Been thanked: 4321 times

Re: iPhone 3.5.3 official feedback thread

Postby AlanOfTheBerg » Tue Feb 19, 2013 4:19 pm

pierino84 wrote:2) When pressing the "share your route" button (I don't know the exact English translation), if my mobile is currently searching for network, waze freezes with the "please wait" alert, and the spinning wheel. It remains so even after the phone is connected to the 3G network. I have to manually kill the app and restart it, in order to clear the screen form the pop-up.

Confirmed this happens in the current iOS beta as well. I will submit this as a bug.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 8.2 | Waze v3.9.4
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23307
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1052 times
Been thanked: 4321 times

Re: iPhone 3.5.3 official feedback thread

Postby AlanOfTheBerg » Thu Feb 21, 2013 4:49 pm

acg521 wrote:In my last comment I brought up the east/west compass arrow mixup, has anyone else had this issue?

It's not a compass-heading indicator. It indicates which direction is North.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 8.2 | Waze v3.9.4
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23307
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1052 times
Been thanked: 4321 times

Re: iPhone 3.5.3 official feedback thread

Postby AlanOfTheBerg » Tue Feb 26, 2013 4:52 pm

KaiEhlig wrote:i switched to a new device and now i'm not able to install the beta versions

who can change my UUID?

You have to submit it as before.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 8.2 | Waze v3.9.4
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23307
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1052 times
Been thanked: 4321 times

Re: iPhone 3.5.3 official feedback thread

Postby cpkendall » Sat Jan 19, 2013 9:25 pm

Seriously Waze, please fix the keyboard on Pioneer devices. It's ridiculous. It used to work a couple of versions ago, and I had high hopes for it being fixed in this version.

I have an AVH-8400BT, and, when it worked, Waze was the best thing on it. Now, and for the last 2 or 3 months - useless.
cpkendall
 
Posts: 2
Joined: Wed Sep 05, 2012 12:47 pm
Has thanked: 0 time
Been thanked: 0 time

Re: iPhone 3.5.3 official feedback thread

Postby Dave2084 » Thu Jan 17, 2013 12:37 pm

V3.5.3 wouldn't install over v3.5.2 for me and left me with a phone that had no useable Waze version. Rebooting didn't help so I was left with no choice but deleting and reinstalling from scratch.

On first use of v3.5.3 there's a typo on the welcome screen:
IMG_2112.PNG
IMG_2112.PNG (219.53 KiB) Viewed 2427 times


After setting it all up the way I had it before all is well apart from I now have no Facebook friends on Waze, yet I do ...
iPhone 4S 32GB (Jailed) • iOS 8.2 • Waze 3.9.6
Level 6 Editor • Lincolnshire Area Manager • UK Country Administrator • iOS Beta Tester
UK WikiUK ForumWaze UK on FacebookBecome a UK Area ManagerWaze Status
Dave2084
Waze Global Champs
Waze Global Champs
 
Posts: 2290
Joined: Tue Feb 09, 2010 12:58 am
Location: Lincoln, UK
Has thanked: 331 times
Been thanked: 321 times

Re: iPhone 3.5.3 official feedback thread

Postby Dave2084 » Thu Jan 17, 2013 6:26 pm

OK, after signing out of Facebook and signing in again the problem is worse (this fixed a similar issue during the 3.5.2 betas) now I cannot sign in at all.

Ready to connect:
IMG_2114.PNG
IMG_2114.PNG (73.67 KiB) Viewed 1828 times

Press OK here:
IMG_2115.PNG
IMG_2115.PNG (146.79 KiB) Viewed 1828 times

Oooops something is broken here:
IMG_2116.PNG
IMG_2116.PNG (62.92 KiB) Viewed 1828 times

After giving on up that installation I deleted Waze, signed out of Facebook and signed back in again and reinstalled Waze. Now I have two friends ...
IMG_2117.PNG
IMG_2117.PNG (55.64 KiB) Viewed 1828 times

Here's all my Facebook/Waze friends from the scoreboard:
Facebook.jpg
Facebook.jpg (55.62 KiB) Viewed 1828 times


I would go back to v3.5.2 and see what gives but since it only lasted a few days I hadn't synced to my PC so don't have a copy. :-(
iPhone 4S 32GB (Jailed) • iOS 8.2 • Waze 3.9.6
Level 6 Editor • Lincolnshire Area Manager • UK Country Administrator • iOS Beta Tester
UK WikiUK ForumWaze UK on FacebookBecome a UK Area ManagerWaze Status
Dave2084
Waze Global Champs
Waze Global Champs
 
Posts: 2290
Joined: Tue Feb 09, 2010 12:58 am
Location: Lincoln, UK
Has thanked: 331 times
Been thanked: 321 times

Re: iPhone 3.5.3 official feedback thread

Postby Dave2084 » Fri Jan 18, 2013 1:41 pm

OK, I have now got it all working, however (for me) there is a serious issue with Facebook and this version (and some previous ones).

After spending all morning trying combinations of deleting, reinstalling, rebooting, signing out of Facebook in iOS Settings, disconnecting from Facebook (app and dashboard) nothing worked.

I decided to see how far back I had to go to get it to work. So I started installing archived versions with iFunbox. 3.5.1.999 (beta) and 3.5.0.0 both failed to connect to my friends. I then went back to 3.0.1.0 which doesn't seem to work at all under iOS 6, so next I tried 3.1.1.0 which worked. I signed into Facebook after logon (no single sign on in this version) and 37 Friends appeared.

I then upgraded to v3.5.3 and so far my friends remain.

Not really a solution as I suspect most users will not have the patience (or archived versions) to do this so upgrades seem to work OK if you already have your friends but (for me at least) a clean install does not seem to do the job.
iPhone 4S 32GB (Jailed) • iOS 8.2 • Waze 3.9.6
Level 6 Editor • Lincolnshire Area Manager • UK Country Administrator • iOS Beta Tester
UK WikiUK ForumWaze UK on FacebookBecome a UK Area ManagerWaze Status
Dave2084
Waze Global Champs
Waze Global Champs
 
Posts: 2290
Joined: Tue Feb 09, 2010 12:58 am
Location: Lincoln, UK
Has thanked: 331 times
Been thanked: 321 times

Re: iPhone 3.5.3 official feedback thread

Postby Dave2084 » Fri Jan 18, 2013 4:10 pm

g0wfv wrote:Installed 3.5.3 over 3.5.2. All OK except no friends in friends list despite being connected to Facebook.

Checking Facebook app settings says that Waze hasn't accessed my friends list since 11 Jan.


When I checked mine it was 10th Jan. Now I've got it working after going back to v3.1.1 (pre single sign on) it says "today". I have since upgraded to v3.5.3 and it's all fine (in that my friends came along for the upgrade ride!).

Need to add a new friend so see if they get picked up or if I'm stuck with the friends I had before.
iPhone 4S 32GB (Jailed) • iOS 8.2 • Waze 3.9.6
Level 6 Editor • Lincolnshire Area Manager • UK Country Administrator • iOS Beta Tester
UK WikiUK ForumWaze UK on FacebookBecome a UK Area ManagerWaze Status
Dave2084
Waze Global Champs
Waze Global Champs
 
Posts: 2290
Joined: Tue Feb 09, 2010 12:58 am
Location: Lincoln, UK
Has thanked: 331 times
Been thanked: 321 times

PreviousNext

Return to Waze App

Who is online

Users browsing this forum: bimk