The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Post Reply

Cartouche not loading maps

Post by JorjGaidin
I've been unable to load maps for the past 2 weeks... I've tried on a number of different systems and just can't figure this one out. I just get a blinking "loading"... Have any ideas?
Posts: 16



Send a message
Shaun Langley
PhD Student @ Michigan State University

Area Manager for Lansing-East Lansing Michigan

Post by AchterHetStuur
I'm currently experiencing something alike at the world-server.

None of the "streets" are drawn. See screenshot. This happens in IE, Firefox and Chrome. Other streettypes are drawn. And also one-way and "no access" are drawn (without a street).

Permalink: ... FTFFFFTTTT
Posts: 184
Send a message
Areamanager: Haaglanden, NL en beheerder van Usernotez!

Post by fpancheri
Same problem here in Brazil. Until yesterday, everything was alright. But now I can't see aerial images anymore. I try Internet Explorer 8.0, Firefox, Chrome... even Opera. Nothing works.
Posts: 33
Been thanked: 1 time
Send a message

Post by FrisbeeDog
I can't see aerial maps or any roads (and yes I do have both layers selected) on the US server.
Posts: 310
Been thanked: 1 time
Send a message
Level 6 Editor
Country Manager: US
Area Manager: Raleigh, Durham, Chapel Hill, and Surrounding Areas of North Carolina

Post by garbatix
Same problem in Poland, since yesterday. :( Tried on Linux and Windows. Both with Firefox. Next aerial doesn't work.

EDIT: It also doesn't work on Chrome. I get only info on URL of one of pics that doesn't load: ... 0011D9.JPG
Posts: 24
Send a message
iPhone 3GS
Area manager in Warsaw and its southwest surroundings

Post by lasitus
Aerial images are showing up for me, for the most part, but a row in the middle of something I want to fix is just white with an error text, like it can't find the file.
Posts: 2
Send a message

Post by RallyChris
First off, what browser are you using? If IE, due to Microsofts ongoing battle to define the internet, it doesn't play well. Recommend using an alternative.

Are you logging into or Based on your sig, should be www

What layers do you have turned on? Some layers take up to a long while to load. Start off small, and just choose roads.

Try going to cartouch through live map, then the update link. If you are going to it via your routes on the dashboard, they might be taking a while to load.
Posts: 2085
Been thanked: 14 times
Send a message
Portland, OR / USA - Mega Mapper
Wiki: Area Manager | Map Editing | Known Issues List
Official Suggestion Websites (hosted by uservoice):
Waze Client | Waze Website / Editor ... 00k_5c.png

Post by shoogy
I am having a similar problem in LA. Maps load in white. when I cycle through "try next aerial photo" option, I can see them refresh to white or show the missing message. This happens on several different computers on Linux and Mac, on both firefox and chrome.

This started the middle of last week sometime. Anyone else having issues?

UPDATE : As of Aug 24th 10am PST it started working for me
Posts: 7
Send a message
Last edited by shoogy on Wed Aug 25, 2010 5:38 am, edited 1 time in total.

Post by support

first of all go to: "View Panel" -> "Try the next aerial photo option"
You need to do it a few times and wait 20 seconds after each time you press the option.

If you don't get the aerial photo, send us Permalink of the aerial.

Waze Team
Waze Team
Posts: 1468
Been thanked: 7 times
Send a message

Post by unwallflower
This happened to me earlier today. I just went back to the live map, typed in my city again, clicked on it, let it load, and then clicked "update map" again. The maps loaded after that.
Posts: 1564
Been thanked: 4 times
Send a message