[SCRIPT] DrivesTabEnhancer v0.6 (Obsolete)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [SCRIPT] DrivesTabEnhancer v0.2 (20130901)

Postby OyyoDams » Wed Sep 04, 2013 1:45 pm

Hi,

I can't get it to work in the beta editor (left panel goes blank).
OyyoDams
Global Champ Mentor
Global Champ Mentor
 
Posts: 4509
Joined: Sun Sep 02, 2012 3:18 pm
Location: France
Has thanked: 380 times
Been thanked: 1063 times

Re: [SCRIPT] DrivesTabEnhancer v0.2 (20130901)

Postby Twister-UK » Mon Sep 02, 2013 7:55 pm

Done...
Twister-UK
Beta tester
Beta tester
 
Posts: 2615
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 391 times
Been thanked: 2269 times

Re: [SCRIPT] DrivesTabEnhancer v0.2 (20130901)

Postby Olestas » Mon Sep 02, 2013 11:51 am

Please change link in first message accordingly to new versions... tried to download version 0.1 with no success until decided to read whole topic.

A useful script anyways.
Olestas
Coordinators
Coordinators
 
Posts: 5680
Joined: Wed Mar 09, 2011 7:08 pm
Location: Latvia
Has thanked: 2716 times
Been thanked: 2021 times

Re: [SCRIPT] DrivesTabEnhancer v0.2 (20130901)

Postby paulkok_my » Mon Sep 02, 2013 1:47 am

Twister-UK wrote:Tweaked the code to respect the 50 drives per page limit imposed by WME...

Firefox+Greasemonkey version: http://userscripts.org/scripts/show/176855
Chrome packaged version: http://crx.chizzum.com/DriveTabEnhancer.0.2.crx

+1

It's working now. Thanks :D
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1072
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 285 times
Been thanked: 231 times

Re: [SCRIPT] DrivesTabEnhancer v0.2 (20130901)

Postby Twister-UK » Sun Sep 01, 2013 10:02 pm

Tweaked the code to respect the 50 drives per page limit imposed by WME...

Firefox+Greasemonkey version: http://userscripts.org/scripts/show/176855
Chrome packaged version: http://crx.chizzum.com/DriveTabEnhancer.crx
Last edited by Twister-UK on Mon Sep 02, 2013 7:55 pm, edited 1 time in total.
Twister-UK
Beta tester
Beta tester
 
Posts: 2615
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 391 times
Been thanked: 2269 times

Re: [SCRIPT] DrivesTabEnhancer v0.1 (20130830)

Postby Twister-UK » Sat Aug 31, 2013 2:58 pm

Thanks for the debug info everyone, looks as if the Waze servers take exception to requests for too many drives at once - this isn't a problem I've seen myself, only having 38 full drives in my own history to play with... I'll need to tweak the script based on whatever the maximum is, and then figure out how to make it obvious which drives are full and which are partial.
Twister-UK
Beta tester
Beta tester
 
Posts: 2615
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 391 times
Been thanked: 2269 times

Re: [SCRIPT] DrivesTabEnhancer v0.1 (20130830)

Postby paulkok_my » Sat Aug 31, 2013 2:25 pm

Wildcard_25 wrote:Getting the same message as paulkok_my with DTE.

Here are the relevant parts of the log.

Code: Select all
DriveTabEnhancer: requesting https://world.waze.com/Descartes-live/app/Archive/MyList?minDistance=1000&offset=70&count=5 dte_0.1.user.js:31
DriveTabEnhancer: received 5 drives dte_0.1.user.js:31
DriveTabEnhancer: 74 drives in history dte_0.1.user.js:31
GET https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=74 406 (Not Acceptable) OL-5fc3da5c.js:13


And, yes, all 74 display a route when clicked on, 75th and older don't :)

At least you can see 74 drives in history. I don't get to see any drives except "Error finding your drives, please try again later.'
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1072
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 285 times
Been thanked: 231 times

Re: [SCRIPT] DrivesTabEnhancer v0.1 (20130830)

Postby WildCard_25 » Sat Aug 31, 2013 2:19 pm

Getting the same message as paulkok_my with DTE.

Here are the relevant parts of the log.

Code: Select all
DriveTabEnhancer: requesting https://world.waze.com/Descartes-live/app/Archive/MyList?minDistance=1000&offset=70&count=5 dte_0.1.user.js:31
DriveTabEnhancer: received 5 drives dte_0.1.user.js:31
DriveTabEnhancer: 74 drives in history dte_0.1.user.js:31
GET https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=74 406 (Not Acceptable) OL-5fc3da5c.js:13


And, yes, all 74 display a route when clicked on, 75th and older don't :)
WildCard_25
Area Manager
Area Manager
 
Posts: 82
Joined: Mon Aug 12, 2013 11:29 am
Location: Toowoomba, QLD, Australia
Has thanked: 64 times
Been thanked: 29 times

Re: [SCRIPT] DrivesTabEnhancer v0.1 (20130830)

Postby paulkok_my » Sat Aug 31, 2013 2:13 pm

Twister-UK wrote:Sounds like it isn't finding any fully available drives for you, which either means there's a URL problem similar to the one I had in WME beta, or you haven't recorded any drives in the past few weeks.

With the script disabled, does WME display a route when you click on the first drive listed in the tab?

If it does, with the script still disabled please can you have a look in the Firebug window or Chrome javascript console when you click on the Drives tab for the first time (or click on one of the page numbers at the end of the tab to show a different set of drives), and let me know which URL is being requested by the tab. On my setup it looks like this:

Code: Select all
https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=5


Thanks

I hope I got it right. With the script disabled, I got this:
Code: Select all
https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=5


With the script enabled, I got this:
Code: Select all
GET https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=108 406 (Not Acceptable)
https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=108
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1072
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 285 times
Been thanked: 231 times

Re: [SCRIPT] DrivesTabEnhancer v0.1 (20130830)

Postby Twister-UK » Sat Aug 31, 2013 7:26 am

Sounds like it isn't finding any fully available drives for you, which either means there's a URL problem similar to the one I had in WME beta, or you haven't recorded any drives in the past few weeks.

With the script disabled, does WME display a route when you click on the first drive listed in the tab?

If it does, with the script still disabled please can you have a look in the Firebug window or Chrome javascript console when you click on the Drives tab for the first time (or click on one of the page numbers at the end of the tab to show a different set of drives), and let me know which URL is being requested by the tab. On my setup it looks like this:

Code: Select all
https://world.waze.com/Descartes-live/app/Archive/List?minDistance=1000&offset=0&count=5


Thanks
Twister-UK
Beta tester
Beta tester
 
Posts: 2615
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 391 times
Been thanked: 2269 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: RichardPyne