[Script] WME Color Highlights - 2.33 Sept 2020

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Color Highlights - 2.1 Nov 2015

Postby GooberKing » Mon Nov 09, 2015 4:16 am

Timbones wrote:
Olestas wrote:When I open editor with places turned on, this thing happens after I click on any place.

I fixed an issue that was occurring on Firefox (v2.2). Let me know if that fixes it.

As for Chrome, I still can't see any problems. What errors do you see in the Developer console?


Not sure what you fixed, but it looks like the HN Panel is now working in Firefox as well. Thanks!
GooberKing
State Manager
State Manager
 
Posts: 451
Joined: Fri Feb 21, 2014 1:05 pm
Location: Rhode Island, USA
Has thanked: 123 times
Been thanked: 56 times

Re: [Script] Colour Highlights for Segments - 1.7.4 Nov 2013

Postby goodolsen » Wed Feb 05, 2014 7:54 pm

Seems like most add-ons that worked before the update to WME need to have their own updates.
Toby G.
Raleigh Area
[ img ][ img ]
goodolsen
 
Posts: 44
Joined: Thu Nov 04, 2010 8:53 pm
Location: North Carolina
Has thanked: 19 times
Been thanked: 6 times

Re: [Script] Colour Highlights for Segments - v1.6.2 Apr 201

Postby HandofMadness » Fri Apr 05, 2013 10:58 pm

kodi75 wrote:Presumably a good portion of the house numbers on the older streets are set / were imported with the help of the geocoding sources. Undoubtedly they need to be tweaked - prompted by UR's.


Why, they aren't currently used by Waze search? The address layer is just there to divert you from working on stuff that actually affects routing, or giving you something to do if there's nothing left in your area. Typically, when Waze announces a new functionality is just around the corner, its 12-24 months out. Since they've yet to make any announcement that they plan on using editor entered addresses "just around the corner", I think its safe to assume we're several years out from them serving any purpose.

/Why yes, I am cynical.
CM: Thailand CM: USA
[ img ]
HandofMadness
Area Manager
Area Manager
 
Posts: 1805
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 377 times

Re: [Script] Colour Highlights for Segments - v1.6.2 Apr 201

Postby HandofMadness » Mon Jul 15, 2013 5:34 pm

Any updated version for the new beta editor URL?
CM: Thailand CM: USA
[ img ]
HandofMadness
Area Manager
Area Manager
 
Posts: 1805
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 377 times

Re: [Script] Colour Highlights for Segments - v1.6.2 Apr 201

Postby HandofMadness » Mon Jul 15, 2013 6:54 pm

AlanOfTheBerg wrote:
shawndoc wrote:Any updated version for the new beta editor URL?

You can update it yourself. Right at the top. Pretty easy.


I know I can unpack the CRX file using 7-Zip. Once I change the URL's in the script, how do I repack it so Chrome will let me install it?
CM: Thailand CM: USA
[ img ]
HandofMadness
Area Manager
Area Manager
 
Posts: 1805
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 377 times

Re: [Script] Colour Highlights for Segments - v1.6.7 Jul 201

Postby HandofMadness » Mon Jul 22, 2013 1:57 am

I'm running 1.6.7 and for some reason I'm not getting any of the AM level functions, despite being a CM.
CM: Thailand CM: USA
[ img ]
HandofMadness
Area Manager
Area Manager
 
Posts: 1805
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 377 times

Re: [Script] Colour Highlights for Segments - v1.7 Oct 2013

Postby HandofMadness » Wed Nov 27, 2013 4:44 am

Timbones wrote:* Updated Chrome version (v1.7.4) so that it will work with non-English languages.


Where do I get 1.7.4? Latest version I'm seeing in the link from the first post is 1.7.1.
CM: Thailand CM: USA
[ img ]
HandofMadness
Area Manager
Area Manager
 
Posts: 1805
Joined: Mon Apr 16, 2012 7:44 am
Location: Californialand, USA
Has thanked: 19 times
Been thanked: 377 times

Re: [Script] WME Color Highlights - 2.25 May 2018

Postby Harmonious4 » Sat Apr 27, 2019 9:14 pm

I have written an update to this script so that the routing preference highlight shows the colour of the routing road type, rather than a cyan highlight for all road types. Where should I be submitting my code?
[ img ][ img ][ img ][ img ][ img ]
PM British Columbia + Ontario
Harmonious4
State Manager
State Manager
 
Posts: 1562
Joined: Sun Feb 26, 2017 7:48 am
Location: Port Moody, BC, Canada
Has thanked: 823 times
Been thanked: 214 times

Re: [Script] WME Color Highlights - 2.30 Sept 2020

Postby Harmonious4 » Thu Sep 03, 2020 9:23 pm

I have also been using a modified version of the script, which changes the colour of the routing preference highlight based on the routing road type rather than always cyan:
Code: Select all
      //newColor = "#0ff";
      switch (attributes.routingRoadType) {
        case 1: // St
          newColor = "#ffffeb";
          break;
        case 2: // PS
          newColor = "#f0ea58";
          break;
        case 3: // FW
          newColor = "#c577d2";
          break;
        case 6: // MH
          newColor = "#45b8d1";
          break;
        case 7: // mH
          newColor = "#69bf88";
      }

Is there any interest in adding this to the script?
[ img ][ img ][ img ][ img ][ img ]
PM British Columbia + Ontario
Harmonious4
State Manager
State Manager
 
Posts: 1562
Joined: Sun Feb 26, 2017 7:48 am
Location: Port Moody, BC, Canada
Has thanked: 823 times
Been thanked: 214 times

Re: [Script] WME Color Highlights - 2.9 JUL 2016

Postby hawkeygoal » Sun Sep 04, 2016 2:52 pm

I haven't deduced a specific cause of the malady, but I'm finding that I'm getting locked in a shaded screen after some edits, particularly if end point nodes have changed in Chrome. I noticed a looping error in the console and identified the faulting instruction was in Color Highlights, specifically ln 736.

VM80754:736 Uncaught TypeError: Cannot read property 'attributes' of undefined



This might be associated with something else I've been noticing (possibly unrelated) that pops up associated with wLib:

VM172751:2 module Waze/Presenter/FeatureEditor/Segment not found


Following this error I'll find seveal 500 level responses from http://www.waze.com. However, I'm not nearly as adept at script writing as I would need to be to do a proper RCA on all this. Just seems something is possibly amiss.
[ img ][ img ][ img ][ img ]
State Manager: Illinois | Area Manager: Iowa | Mentor
Illinois: Wiki Forum Facebook Twitter | WME: Wiki What to Edit Glossary
My Twitter: @hawkeygoal

Improving the map, one edit at a time. What's your goal?
GO HAWKS! There's only ONE GOAL!
hawkeygoal
State Manager
State Manager
 
Posts: 247
Joined: Sun Aug 31, 2014 5:05 pm
Location: Darien, IL, USA
Has thanked: 107 times
Been thanked: 114 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: juliansean, Mapman44, steveinark