[Script] UROverview Plus v3.7 (20140330)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: krankyd, Unholy

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] UROverview v1.12 (20121205)

Postby Twister-UK » Sat Dec 22, 2012 10:21 pm

TonyG-UK wrote:This is causing a problem with the display of approved speed cameras with the latest WME update. They disappear from the map.


I haven't been able to replicate this. Please check the URO filtering options to make sure the "show approved cameras" checkbox hasn't been cleared, and if everything looks OK there then try re-installing the script.
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.14 (20121227)

Postby Twister-UK » Thu Dec 27, 2012 10:38 pm

iainhouse wrote:When filtering URs including/excluding a particular string, could that be done case-insensitively?


Done, 1.14 adds a "case-insensitive" checkbox which applies to both present and absent keyword filters.

http://userscripts.org/scripts/show/145186
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.14 (20121227)

Postby Twister-UK » Sun Dec 30, 2012 2:41 pm

mssusa wrote:Still not showing approved cameras (speed and red light) for me no matter what I do.

Chrome 23.0.1271.64 on 64bit Win 7.


I wouldn't have expected 1.14 to have fixed this, since I still don't know why some of you are having this problem... I think I might have to release a version of the script that allows debug data to be captured from your WME sessions, because I'm not seeing anything here that would cause it.
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.14 (20121227)

Postby Twister-UK » Wed Jan 02, 2013 9:45 pm

Update re the approved camera issue noted by mssusa and TonyG-UK:

Thanks to their assistance and a debug version of the script, it's been established that in some instances the "Hide Updated By Me" checkbox at the bottom of the Cameras tab can end up being ticked when the script is updated, contrary to what its default state ought to be.

If anyone else is seeing the same problem - some/all approved cameras disappearing from view when the script is enabled - please check the state of this option even if you know you've never selected it.
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.15 (20130102)

Postby Twister-UK » Wed Jan 02, 2013 10:08 pm

Quick update to 1.15, to introduce support for filtering out the "Waze Automatic" general error URs that are now cluttering up parts of the US map (and will presumably also be infecting the international maps sooner or later...) making it difficult to deal with user-submitted URs.

http://userscripts.org/scripts/show/145186
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.15 (20130102)

Postby Twister-UK » Fri Jan 11, 2013 10:28 pm

iainhouse wrote:What I've just noticed is that the shortening to "here" only happens if the URL starts with "http". When I create a UR with an "https" link, the address appears in full.


Not any more :D 1.16 also now provides a dedicated Roadworks filter checkbox, so they can be quickly hidden.

http://userscripts.org/scripts/show/145186
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.17 (20130114)

Postby Twister-UK » Mon Jan 14, 2013 1:55 pm

Another small update brings us to 1.17... the UR tab now adds an "Invert operation..." checkbox, which inverts the behaviour of the UR types checkboxes - instead of showing only those UR types which AREN'T checked off, it will now show only those UR types which ARE checked off.

http://userscripts.org/scripts/show/145186
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.18 (20130126)

Postby Twister-UK » Sat Jan 26, 2013 12:54 am

With the more frequent appearance of map problem markers on the UK map, I noticed that the previous versions of URO didn't allow problem markers to be filtered out by their solved/not identified states, or for them to be marked as hidden for the current editing session. 1.18 now resolves that omission...

http://userscripts.org/scripts/show/145186
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.19 (20130221)

Postby Twister-UK » Thu Feb 21, 2013 11:39 am

At last, a beta-friendly update for URO! This version should probably be subtitled "The Timbones Edition", as without his help I think I'd still be bashing my head against the nearest solid object trying to figure out how to handle the new-look UR/problem markers in the current WME beta (and presumably coming soon to the public version...).

For non-beta users, there are also a couple of minor bug fixes - the livemap links are now correctly formatted in the popups for all types of marker, and the misalignment of camera popups if the camera layer is turned off, the map panned/zoomed, and the camera layer then turned on again has been fixed.

Unfortunately for Chrome users, there's also a more obvious change. Due to the appearance of random errors when using the "Open in new WME tab" links on UR and problem marker popups in the current release version of WME, I've had to disable the automatic opening of the UR/problem details on the new tab. The new tab will still get opened, however the user will then have to click on the marker themselves to open up the details pane. Chrome + WME beta isn't affected, nor is Firefox with either version of WME.

http://userscripts.org/scripts/show/145186


Now let's see how long it takes Waze to come up with another rewrite of WME which breaks URO again...
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

Re: [Script] UROverview v1.19 (20130221)

Postby Twister-UK » Sat Mar 02, 2013 9:21 am

That's an initialisation error, please try uninstalling then reinstalling the script to see if something went wrong in the update process.

If that doesn't solve things, then either there's some odd interaction happening with another script (what else do you have running?) or, more likely, Waze have gone and fiddled with WME again... Is this the normal version of WME or the beta test version?
L4 AM for NW London and Shetland Islands - HTC One X/Android 4.1.1
WME/Livemap enhancement scripts @ userscripts.org and Chrome Web Store
Twister-UK
 
Posts: 858
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 44 times
Been thanked: 325 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: No registered users