Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by abc1357
I am in the US and was using Validator on Chrome. It stopped working for me today. I tried reinstalling 1.1.16 and all it says is "Sorry, You cannot use WME Validator over here. Please check the forum thread
for more information." I couldn't find any info in this thread
abc1357
State Manager
State Manager
Posts: 498
Has thanked: 227 times
Been thanked: 188 times
-- abc1357 --


Post by abc1357
I have determined that this is probably due to a bug in WME that caused my username to be [missing %{username} value]. There's a separate topic on this.
abc1357
State Manager
State Manager
Posts: 498
Has thanked: 227 times
Been thanked: 188 times
-- abc1357 --


Post by aBshield
bmtg wrote:New version of WME interface rolled out this morning. No more "me" tab, and therefore no more Validator settings. And the script doesn't appear to work, at least on my system.

bmtg
Just for some additional confirmation, I see the same.
aBshield
Waze Mentor
Waze Mentor
Posts: 308
Has thanked: 77 times
Been thanked: 40 times

Post by aBshield
Restricted turns are now absolute and no longer penalty based, which can cause problems when all access into an area, such as a dead-end or a private installation, are restricted. Full details here, but essentially the route ends early and potentially in erroneous locations.

I thought I'd flag this here in case this is something WME Validator could potentially test for. As I write this though, didn't we have something like this way back? Was this impacted by the same change that lost some other functionality?
aBshield
Waze Mentor
Waze Mentor
Posts: 308
Has thanked: 77 times
Been thanked: 40 times


Post by aBshield
ldriveskier wrote:I am VERY happy that Validator is working again. Thank you!!! However, I get a pop-up every time I open a page in WME or hard refresh WME. I don't know if it is something that changed in Validator or an incorrect setting on my end, but it is annoying. Can someone help to get rid of this please?

Thank you!
The Validator version hasn't incremented from early November. I'd venture a guess that WME changed in such a way that Validator appears functional again, but it doesn't look like it was specifically updated to be compatible with recent WME versions. That could explain why the disclaimer keeps popping up and perhaps other functionality may not be solid.
aBshield
Waze Mentor
Waze Mentor
Posts: 308
Has thanked: 77 times
Been thanked: 40 times

AeRoBianCo
Beta tester
Beta tester
Posts: 1796
Has thanked: 979 times
Been thanked: 652 times
images/ranks/SMbadge.pngimages/ranks/Mentor_Badge_63px.pngimages/ranks/BetaTester_Badge.pnghttps://tomputtemans.com/images/WazeWMEbeta.pnghttps://s.waze.tools/s0700.png
Supervisor Regional Sureste (Chiapas, Guerrero, Oaxaca).
State Manager (Puebla).
Ex-México Country Manager y Ex-Local Champ. :(

Post by AeRoBianCo
dspille wrote:
ali_zali wrote:hi guys
what should i do with this error???
You should read the discussion above, but Validator is no more. Check out the new replacement, WME Magic.
WME Magic
AeRoBianCo
Beta tester
Beta tester
Posts: 1796
Has thanked: 979 times
Been thanked: 652 times
images/ranks/SMbadge.pngimages/ranks/Mentor_Badge_63px.pngimages/ranks/BetaTester_Badge.pnghttps://tomputtemans.com/images/WazeWMEbeta.pnghttps://s.waze.tools/s0700.png
Supervisor Regional Sureste (Chiapas, Guerrero, Oaxaca).
State Manager (Puebla).
Ex-México Country Manager y Ex-Local Champ. :(

Post by afrenchpress
Great tool! Just commenting to provide that "motivation"
afrenchpress
Posts: 145
Has thanked: 79 times
Been thanked: 6 times

AlanOfTheBerg
EmeritusChamps
EmeritusChamps
Posts: 23624
Has thanked: 610 times
Been thanked: 3679 times
Wiki Resources: Map Editing Manual | mailto:?subject=&body=
Oregon-based US Country Manager | iPhone6 - VZ