These forums are specific to the Waze mobile app. Post here if you experienced a problem while using the app, have a question about the app functionality or a feature such as navigation or search.

Post Reply
Forum rules
Waze App Useful Resources

Unable to run Waze

Post by tiagobt
Hello,

I've tried to install Waze 2.0.3.0 today (latest version in the Market), but I got the following error message when I opened the application for the first time:
Unable to run waze

Ooops, we've encountered a problem.
We suggest you restart your phone and try again.
I've already restarted the phone quite a few times, but I still have the problem. I've also tried to reinstall Waze, but the same error happens every time. I'm running Android 2.1 on an HTC Hero.

Is there any way to solve this problem? Waze used to work fine on my phone in Android 2.1, 2.2 and 2.3.

Thanks a lot,
Tiago
tiagobt
Posts: 32

POSTER_ID:99788

1

Send a message

Post by tiagobt
The crash log is the following:

Code: Select all

I/ActivityManager( 1740): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.waze/.FreeMapAppActivity }
I/ActivityManager( 1740): Start proc com.waze for activity com.waze/.FreeMapAppActivity: pid=2725 uid=10068 gids={3003, 1015, 1007, 1006}
W/dalvikvm( 1740): disableGcForExternalAlloc: false
D/dalvikvm( 2725): GC freed 1716 objects / 140600 bytes in 105ms
D/dalvikvm( 2725): GC freed 924 objects / 49288 bytes in 251ms
W/Rosie   ( 1816): mAddHtcWidgetByOtherActivity = false, mIsOpenSlideWhenLeaveLaunch = true
W/Service ( 2725): setForeground: ignoring old API call on com.waze.FreeMapAppService
W/WAZE Service( 2725): Service started. Instance: com.waze.FreeMapAppService@47a08de8
I/WAZE    ( 2725): Available space at /sdcard: 7275986944
D/Freemap installation( 2725): Resources extraction unnecessary
I/ActivityManager( 1740): Displayed activity com.waze/.FreeMapAppActivity: 1377 ms (total 1377 ms)
D/dalvikvm( 2725): Trying to load lib /data/data/com.waze/libandroidroadmap.so 0x47a04bd0
D/dalvikvm( 2725): Added shared lib /data/data/com.waze/libandroidroadmap.so 0x47a04bd0
D/dalvikvm( 2725): No JNI_OnLoad found in /data/data/com.waze/libandroidroadmap.so 0x47a04bd0
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'InitCanvasNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitCanvasNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'InitCanvasNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'InitCanvasNTV' (wrong CL)
D/libEGL  ( 2725): loaded /system/lib/egl/libGLES_android.so
D/libEGL  ( 2725): loaded /system/lib/egl/libGLES_qcom.so
D/EGL.oem ( 2725): smi: offset=10000000, len=00700000, phys=0x0
D/EGL.oem ( 2725): ebi: offset=00000000, len=00800000, phys=0x25800000
D/EGL.oem ( 2725): reg: offset=20000000, len=00100000, phys=0xa0000000
E/WAZE    ( 2725): EGL error in CreateEglSurface eglMakeCurrent. Error code: 12290
E/WAZE    ( 2725): Egl surface initialization failed. Exiting the application!!!
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'InitMenuManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitMenuManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'InitMenuManagerNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'InitMenuManagerNTV' (wrong CL)
D/LocationManager( 2725): Constructor: service = android.location.ILocationManager$Stub$Proxy@47a3fc20
D/NetworkLocationProvider( 1740): addListener(): com.waze
D/NetworkLocationProvider( 1740): setMinTime: 0
D/NetworkLocationProvider( 1740): enableLocationTracking(): true
D/NetworkLocationProvider( 1740): getLocation(): triggering a wifi scan
D/WifiService( 1740): acquireWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.Binder@47dff7d0}
D/WifiService( 1740): enable and start wifi due to updateWifiState
D/NetworkLocationProvider( 1740): onCellLocationChanged [40111,7305707]
W/GpsLocationProvider( 1740): Duplicate add listener for com.waze
D/LocationManagerService( 1740): Acquired wakelock
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'AppStartNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'AppStartNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'AppStartNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'AppStartNTV' (wrong CL)
I/wpa_supplicant( 1459): CTRL-EVENT-SCAN-RESULTS  Ready
I/wpa_supplicant( 1459): - wpa_supplicant_event_scan_results RETURN (ap_scan = 2)-
D/NetworkLocationProvider( 1740): updateWifIScanResults(): 6 APs
D/LocationMasfClient( 1740): getNetworkLocation(): Returning cache location with accuracy 60.0
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'NativeMsgDispatcherNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'NativeMsgDispatcherNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'NativeMsgDispatcherNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'NativeMsgDispatcherNTV' (wrong CL)
D/Sensors ( 1740): open_akm, fd=136
D/gralloc ( 1740): allocating GPU size=294912, offset=0
D/dalvikvm( 2725): +++ not scanning '/system/lib/libwebcore.so' for 'LocListenerCallbackNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libmedia_jni.so' for 'LocListenerCallbackNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libexif.so' for 'LocListenerCallbackNTV' (wrong CL)
D/dalvikvm( 2725): +++ not scanning '/system/lib/libsrec_jni.so' for 'LocListenerCallbackNTV' (wrong CL)
D/LocationManagerService( 1740): Released wakelock
D/AK8973  ( 1729): Compass Start
D/gralloc ( 1740): allocating GPU size=294912, offset=294912
D/WifiService( 1740): releaseWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.Binder@47dff7d0}
D/WifiService( 1740): enable and start wifi due to updateWifiState
D/dalvikvm( 1740): GC freed 24434 objects / 1230296 bytes in 270ms
W/WAZE Service( 2725): Service destroy.
D/JOGBALL ( 1740): Jogball, + set_jogball_mode mode=0
W/InputManagerService( 1740): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@47f8d118
D/Sensors ( 1740): close_akm, fd=136
W/dalvikvm( 1740): disableGcForExternalAlloc: false
W/MessageQueue( 2725): Handler{47a012b8} sending message to a Handler on a dead thread
W/MessageQueue( 2725): java.lang.RuntimeException: Handler{47a012b8} sending message to a Handler on a dead thread
W/MessageQueue( 2725): at android.os.MessageQueue.enqueueMessage(MessageQueue.java:181)
W/MessageQueue( 2725): at android.os.Handler.sendMessageAtTime(Handler.java:457)
W/MessageQueue( 2725): at android.os.Handler.sendMessageDelayed(Handler.java:430)
W/MessageQueue( 2725): at android.os.Handler.sendMessage(Handler.java:367)
W/MessageQueue( 2725): at android.os.Message.sendToTarget(Message.java:319)
W/MessageQueue( 2725): at com.waze.FreeMapNativeManager.PostNativeMessage(FreeMapNativeManager.java:526)
W/MessageQueue( 2725): at com.waze.FreeMapNativeTimerTask.run(FreeMapNativeTimerTask.java:74)
W/MessageQueue( 2725): at java.util.Timer$TimerImpl.run(Timer.java:290)
I/AndroidRuntime( 2725): AndroidRuntime onExit calling exit(0)
E/JavaBinder( 2725): Unknown binder error code. 0xfffffff7
I/ActivityManager( 1740): Process com.waze (pid 2725) has died.
I/WindowManager( 1740): WIN DEATH: Window{47e62dc8 SurfaceView paused=false}
E/GpsLocationProvider( 1740): GPS status listener died
W/GpsLocationProvider( 1740): Unneeded remove listener for android.uid.system:1000
D/NetworkLocationProvider( 1740): removeListener(): com.htc.UpgradeSetup
D/NetworkLocationProvider( 1740): removeListener(): com.htc.wdm
D/NetworkLocationProvider( 1740): removeListener(): com.htc.android.htcsetupwizard
D/NetworkLocationProvider( 1740): removeListener(): com.htc.AddProgramWidget
D/NetworkLocationProvider( 1740): removeListener(): com.htc.settings.accountsync
D/gralloc ( 1740): freeing GPU buffer at 0
D/gralloc ( 1740): freeing GPU buffer at 294912
I/WindowManager( 1740): WIN DEATH: Window{47e36fc0 com.waze/com.waze.FreeMapAppActivity paused=false}
Any idea what's causing it?
tiagobt
Posts: 32
Send a message

Post by tiagobt
I've just tried the latest beta (2.1.99.106), but the same error happened. The crash log looks very similar, but here it goes:

Code: Select all

I/ActivityManager(  617): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.waze/.FreeMapAppActivity }
I/ActivityManager(  617): Start proc com.waze for activity com.waze/.FreeMapAppActivity: pid=6233 uid=10068 gids={3003, 1015, 1007, 1006}
W/dalvikvm(  617): disableGcForExternalAlloc: false
W/Rosie   (  684): mAddHtcWidgetByOtherActivity = false, mIsOpenSlideWhenLeaveLaunch = true
D/dalvikvm( 6233): GC freed 1929 objects / 155464 bytes in 138ms
I/ActivityManager(  617): Process com.levelup.beautifulwidgets (pid 6215) has died.
D/dalvikvm( 6233): GC freed 538 objects / 33408 bytes in 79ms
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47e9ce18 duration=1
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47be9508 duration=1
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47be5920 duration=1
D/dalvikvm(  617): GC freed 17841 objects / 922808 bytes in 547ms
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@48337ad0 duration=1
I/WAZE    ( 6233): Available space at /sdcard: 7271247872
D/Freemap installation( 6233): Resources extraction unnecessary
D/dalvikvm( 6233): Trying to load lib /data/data/com.waze/lib/libwaze.so 0x47c7cbd0
D/dalvikvm( 6233): Added shared lib /data/data/com.waze/lib/libwaze.so 0x47c7cbd0
D/dalvikvm( 6233): No JNI_OnLoad found in /data/data/com.waze/lib/libwaze.so 0x47c7cbd0
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'WazeLogNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitResManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitResManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitResManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitNativeManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'SetUpgradeRunNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitCanvasNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitCanvasNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitCanvasNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitTimerManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitSoundManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitMenuManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitMenuManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitMenuManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitSoundRecorderNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitSoundRecorderNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitSoundRecorderNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitSpeechttManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitSpeechttManagerNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitSpeechttManagerNTV' (wrong CL)
D/LocationManager( 6233): Constructor: service = android.location.ILocationManager$Stub$Proxy@47c9bd90
D/NetworkLocationProvider(  617): addListener(): com.waze
D/NetworkLocationProvider(  617): setMinTime: 0
D/NetworkLocationProvider(  617): enableLocationTracking(): true
D/NetworkLocationProvider(  617): getLocation(): triggering a wifi scan
D/WifiService(  617): acquireWifiLockLocked: WifiLock{NetworkLocationProvider type=2 binder=android.os.Binder@47de7e28}
D/WifiService(  617): enable and start wifi due to updateWifiState
W/GpsLocationProvider(  617): Duplicate add listener for com.waze
D/LocationManagerService(  617): Acquired wakelock
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitMsgBoxNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'InitNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'InitNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'InitNTV' (wrong CL)
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47f55ea8 duration=1
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'BackLightMonitorResetNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'BackLightMonitorResetNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'BackLightMonitorResetNTV' (wrong CL)
W/WAZE Service( 6233): Service started. Instance: com.waze.FreeMapAppService@47d0fb50
I/wpa_supplicant( 4745): CTRL-EVENT-SCAN-RESULTS  Ready
I/wpa_supplicant( 4745): - wpa_supplicant_event_scan_results RETURN (ap_scan = 2)-
D/LocationManagerService(  617): Released wakelock
D/libEGL  ( 6233): loaded /system/lib/egl/libGLES_android.so
D/NetworkLocationProvider(  617): onCellLocationChanged [5211,1211]
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47e7fba0 duration=1
D/libEGL  ( 6233): loaded /system/lib/egl/libGLES_qcom.so
D/EGL.oem ( 6233): smi: offset=10000000, len=00700000, phys=0x0
D/EGL.oem ( 6233): ebi: offset=00000000, len=00800000, phys=0x25800000
D/EGL.oem ( 6233): reg: offset=20000000, len=00100000, phys=0xa0000000
E/WAZE    ( 6233): EGL error in CreateEglSurface eglMakeCurrent. Error code: 12290
E/WAZE    ( 6233): Egl surface initialization failed. Exiting the application!!!
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'SetBackgroundRunNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'SetBackgroundRunNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'SetBackgroundRunNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'CanvasConfigureNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'CanvasConfigureNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'CanvasConfigureNTV' (wrong CL)
D/NetworkLocationProvider(  617): updateWifIScanResults(): 9 APs
D/LocationMasfClient(  617): getNetworkLocation(): Returning cache location with accuracy 58.0
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47e62b80 duration=1
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'CreateCanvasNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'CreateCanvasNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'CreateCanvasNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'CanvasRedrawNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'CanvasRedrawNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'CanvasRedrawNTV' (wrong CL)
I/ActivityManager(  617): Displayed activity com.waze/.FreeMapAppActivity: 5498 ms (total 5498 ms)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'AppStartNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'AppStartNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'AppStartNTV' (wrong CL)
D/LocationManagerService(  617): Acquired wakelock
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47e34a88 duration=1
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'ShowGpsDisabledWarningNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'NativeMsgDispatcherNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'NativeMsgDispatcherNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'NativeMsgDispatcherNTV' (wrong CL)
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47e32bb8 duration=1
D/dalvikvm( 6233): +++ not scanning '/system/lib/libwebcore.so' for 'LocListenerCallbackNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libmedia_jni.so' for 'LocListenerCallbackNTV' (wrong CL)
D/dalvikvm( 6233): +++ not scanning '/system/lib/libexif.so' for 'LocListenerCallbackNTV' (wrong CL)
D/LocationManagerService(  617): Released wakelock
D/TelephonyRegistry(  617): notifyDataConnection() state=0isDataConnectivityPossible()true, reason=null
D/TelephonyRegistry(  617): broadcastDataConnectionStateChanged()  state=DISCONNECTEDtypes=null, interfaceName=null
D/NetworkLocationProvider(  617): onDataConnectionStateChanged 8
D/NetworkLocationProvider(  617): onCellLocationChanged [40111,7305707]
I/NotificationService(  617): enqueueToast pkg=com.waze callback=android.app.ITransientNotification$Stub$Proxy@47de4eb8 duration=1
D/PhoneApp(  678): [NotificationMgr] updateNetworkSelection()...state = 0 new network 
D/PhoneApp(  678): [NotificationMgr] hideDataDisconnectedRoaming()...
D/gralloc (  617): allocating GPU size=294912, offset=0
D/gralloc (  617): allocating GPU size=294912, offset=294912
D/Sensors (  617): open_akm, fd=190
D/AK8973  (  588): Compass Start
I/BatteryStatsImpl(  617): notePhoneSignalStrengthLocked: 4->3
D/BT HS/HF(  678): gsmAsuToSignal=12
D/LocationMasfClient(  617): getNetworkLocation(): Returning cache location with accuracy 58.0
D/LocationManagerService(  617): Acquired wakelock
D/LocationManagerService(  617): Released wakelock
W/InputManagerService(  617): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@47d78538
W/WAZE Service( 6233): Service destroy.
D/JOGBALL (  617): Jogball, + set_jogball_mode mode=0
W/MessageQueue( 6233): Handler{47c7e0c8} sending message to a Handler on a dead thread
W/MessageQueue( 6233): java.lang.RuntimeException: Handler{47c7e0c8} sending message to a Handler on a dead thread
W/MessageQueue( 6233): at android.os.MessageQueue.enqueueMessage(MessageQueue.java:181)
W/MessageQueue( 6233): at android.os.Handler.sendMessageAtTime(Handler.java:457)
W/MessageQueue( 6233): at android.os.Handler.sendMessageDelayed(Handler.java:430)
W/MessageQueue( 6233): at android.os.Handler.sendMessage(Handler.java:367)
W/MessageQueue( 6233): at android.os.Message.sendToTarget(Message.java:319)
W/MessageQueue( 6233): at com.waze.FreeMapNativeManager.PostPriorityNativeMessage(FreeMapNativeManager.java:661)
W/MessageQueue( 6233): at com.waze.FreeMapNativeTimerTask.run(FreeMapNativeTimerTask.java:72)
W/MessageQueue( 6233): at java.util.Timer$TimerImpl.run(Timer.java:290)
I/AndroidRuntime( 6233): AndroidRuntime onExit calling exit(0)
D/ActivityManager(  617): foreground app died, app = com.waze
I/ActivityManager(  617): Process com.waze (pid 6233) has died.
Unwallflower, what exactly do you mean by a fresh install? I uninstalled the app using Android Market and then deleted the "waze" folder from the SD card. Is that enough?

Any other ideas?

Thanks again,
Tiago
tiagobt
Posts: 32
Send a message

Post by tiagobt
I've just realized the ROM I'm using has recently updated the Qcom EGL library to the latest version. And the problem didn't happen in previous versions. Is there a known issue with the latest version of the library?
tiagobt
Posts: 32
Send a message

Post by unwallflower
Can you try one of the latest betas? I'm not sure how that would make a difference, but it might. Make sure you try a fresh install (remove all Waze data from your phone before installing the beta).
unwallflower
Posts: 1564
Been thanked: 4 times
Send a message