[Script] WME Validator 1.1.7 / 06.03.2015

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderator: Unholy

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby bz2012 » Sun Jul 27, 2014 5:22 pm

FIrst time I have tried using the TYPE ferry, I see a problem: It is flagged as 'non drivable connected to drivable'.

Although literally, a ferry route isn't 'drivable', the vehicle enters and leaves the segment at the ends, so the segment NEEDS to be connected to drivables at both ends and should be treated by Validator as drivable.
State Manager, Louisiana
bz2012
Map Raider
Map Raider
 
Posts: 1223
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 494 times
Been thanked: 202 times

Re: [Script] WME Validator 1.0.3 / 04.08.2014

Postby bz2012 » Sun Aug 24, 2014 1:50 pm

It appears that a recent update of WME has broken Validator.
It is now flagging ALL segments as 'no inward connectivity', 'no outward connectivity'.

This is true, even with ALL other extensions disabled.

Discussion in the WME thread shows that the same problem was known to exist in the beta WME.
Last edited by bz2012 on Sun Aug 24, 2014 2:19 pm, edited 1 time in total.
State Manager, Louisiana
bz2012
Map Raider
Map Raider
 
Posts: 1223
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 494 times
Been thanked: 202 times

Re: [Script] WME Validator 1.0.4 / 24.08.2014

Postby bz2012 » Sun Aug 24, 2014 3:17 pm

NIce fast response. THANK YOU!!!!!!
State Manager, Louisiana
bz2012
Map Raider
Map Raider
 
Posts: 1223
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 494 times
Been thanked: 202 times

Re: [Script] WME Validator 1.1.6 / 06.01.2015

Postby bz2012 » Thu Jan 22, 2015 10:25 am

A hidden problem that was not flagged by validator?
https://www.waze.com/editor/?env=usa&lo ... 3,83339691
These two segments 'met' but no 'turn arrow' was visible at the meeting point.

The segments were at different elevations and had somehow been brought into proximity without being connected.

I can remember when WME did not connect in a case like that. I used to need to temporarily change the elevation of one segment to match the other before I could connect them. In this case, I just grabbed the west end of the eastern segment and moved it away, dropped it, and then moved it back and it connected. I then allowed the turn. I think that should fix the 'no routing through that junction' problem.

I expected Validator to be flagging both segments and saying that the drivables were not connected, there was no such flagging nor message shown when either was selected.
State Manager, Louisiana
bz2012
Map Raider
Map Raider
 
Posts: 1223
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 494 times
Been thanked: 202 times

Re: [Script] WME Validator 1.1.6 / 06.01.2015

Postby bz2012 » Wed Feb 25, 2015 10:56 pm

sketch wrote:This is what I have written down. I haven't verified or updated it recently. For example, you can see that Ferry isn't in there.
Code: Select all
typeRank
15 freeway
14 major highway
13 minor highway
12 ramp
11 primary street
10 street   ***** broken ******  highlights street and service road.
9 service road   **** broken ******  highlights nothing
8 dirt road
7 parking lot road
6 private road
5 walking trail
4 pedestrian bdwk
3 stairway
2 railroad
1 runway


type
1 street
2 primary street
3 freeway
4 ramp
5 walking trail
6 major hwy
7 minor hwy
8 dirt
9
10 ped boardwalk
11
12
13
14
15
16 stairway
17 private road
18 railroad
19 runway
20 parking lot road
21 service road

2015-02-25_164731.jpg
2015-02-25_164731.jpg (129.96 KiB) Viewed 141 times

2015-02-25_164542.jpg
2015-02-25_164542.jpg (138.93 KiB) Viewed 141 times

https://www.waze.com/editor/?env=usa&lo ... 388&zoom=6

I have not found one for ferry, yet.

And the Service Road is not really broken, it just seems like all service roads have been converted to street. xxxx scratch that.... the service road seems to now be a NULL type, and being flagged as non drivable connected to drivable! strange.

That happened for no apparent reason. I saw a '1' in the save box, hit save, got an error and canceled the save and then I see this:
2015-02-25_170509.jpg
2015-02-25_170509.jpg (139.76 KiB) Viewed 138 times


By the way, the segments with the line in them are being highlighted by WME color highlights as 'NON-Drive-able.
A bit odd that railroads are NOT being flagged as non drivable and Ferry is.
State Manager, Louisiana
bz2012
Map Raider
Map Raider
 
Posts: 1223
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 494 times
Been thanked: 202 times

Not working need to reinstall validator?

Postby cactusmonkey1966 » Sun Feb 23, 2014 1:32 am

Hi!
I'm a new area manager, and installed this WME Validator and it shows installed on my Chrome. However, since we've been having problems with saving map edits I made a mistake. I erased some js script extensions on my computer control panel, and now Validator isn't working at all. My editing screen keeps saying zoom out to start WME Validator. And then it doesn't work well or at all. A few times today it let me start the play button and create a report, but now nothing... :oops:

I'm thinking I need to delete WME Validator and reinstall it. But my Chrome doesn't seem to give me that option. Any insight into getting this installed properly now that I messed up and played around without knowing what I'm doing?
Image
Have you read Wiki yet? What's your favorite Wiki?
Area Manager Las Vegas Metropolitan area, Boulder City, Pahrump and Reno/Sparks NV
Map Editing Quick Start Guide
How to use PLACES
cactusmonkey1966
Area Manager
Area Manager
 
Posts: 30
Joined: Wed Nov 13, 2013 8:01 pm
Location: Las Vegas valley area, Boulder City, Pahrump
Has thanked: 23 times
Been thanked: 6 times

Re: [Script] WME Validator 0.9.9 (BETA) / 27.04.2014

Postby carloslaso » Sun May 11, 2014 6:02 pm

OlavoAG wrote:Where can I download it? userscripts.org seems not to be working... :?
For Firefox


Userscripts has been unstable lately, funny the first google result for that search:

Image
Image Image
Image Coordinador de Comunidad en México / Foro de México / Anuncios de Waze
Supervisor Noroeste: BC, BCS, SON, SIN, CHH, DUR

iPhone 6+ - iOS 8.3ß3 - Waze 3.9.4 / @carloslaso
carloslaso
Coordinators
Coordinators
 
Posts: 820
Joined: Fri Aug 20, 2010 1:30 am
Location: Sonora, Mexico
Has thanked: 292 times
Been thanked: 439 times

Re: [Script] WME Validator 0.9.9 (BETA) / 27.04.2014

Postby carloslaso » Mon May 12, 2014 7:14 am

sketch wrote:I like to use http://www.downforeveryoneorjustme.com/ for that purpose.


So do I but that is the first result that came up on the search instead of the site itself.
Image Image
Image Coordinador de Comunidad en México / Foro de México / Anuncios de Waze
Supervisor Noroeste: BC, BCS, SON, SIN, CHH, DUR

iPhone 6+ - iOS 8.3ß3 - Waze 3.9.4 / @carloslaso
carloslaso
Coordinators
Coordinators
 
Posts: 820
Joined: Fri Aug 20, 2010 1:30 am
Location: Sonora, Mexico
Has thanked: 292 times
Been thanked: 439 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby carloslaso » Tue Jun 03, 2014 8:07 am

qwaletee wrote:Just FYI, here is the list of codes for each ${type}:
...

Excuse the RegEx tutorial :)


Thanks for the tutorial, it is going straight to my evernote.
Image Image
Image Coordinador de Comunidad en México / Foro de México / Anuncios de Waze
Supervisor Noroeste: BC, BCS, SON, SIN, CHH, DUR

iPhone 6+ - iOS 8.3ß3 - Waze 3.9.4 / @carloslaso
carloslaso
Coordinators
Coordinators
 
Posts: 820
Joined: Fri Aug 20, 2010 1:30 am
Location: Sonora, Mexico
Has thanked: 292 times
Been thanked: 439 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby carloslaso » Mon Aug 04, 2014 6:18 am

alexschrod wrote:Luckily, Javascript itself is incredibly malleable, so instead of modifying the script, let's modify a part of Javascript that the script relies on instead ... at least in Firefox, adding this peace of code directly under the LICENSE comment in the Greasemonkey script makes the script work again:

Code: Select all
Date.now = function() {
};


Mind you, this may break all kinds of things, but as an emergency procedure while we wait for a new update, it works.

paulkok_my wrote:Just tried it under Tampermonkey and it works for Chrome.


I can confirm it works in chrome

Image
Image Image
Image Coordinador de Comunidad en México / Foro de México / Anuncios de Waze
Supervisor Noroeste: BC, BCS, SON, SIN, CHH, DUR

iPhone 6+ - iOS 8.3ß3 - Waze 3.9.4 / @carloslaso
carloslaso
Coordinators
Coordinators
 
Posts: 820
Joined: Fri Aug 20, 2010 1:30 am
Location: Sonora, Mexico
Has thanked: 292 times
Been thanked: 439 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: No registered users