[Script] WME Validator 2020.04.12 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 2018.11.10 (BETA)

Postby berestovskyy » Sun Dec 09, 2018 10:20 am

yaacobyy wrote:There is a problem with this error:
Same endpoints drivable segments (slow) (#78)


Thanks for the report. Could you please provide a permalink?
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2018.11.10 (BETA)

Postby berestovskyy » Sun Dec 09, 2018 5:39 pm

Thanks, yaacobyy. Will be fixed in the next release.
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2018.11.10 (BETA)

Postby berestovskyy » Mon Dec 10, 2018 4:01 pm

jm6087 wrote:I agree, it is written in the wiki not to have a segment connect to the same segment twice and should still be considered an issue.


I have reread the wiki prior the change. It's not quite clear what "two ways" means:

There are two or more ways to get from one junction node to another without going through any other nodes. They can cause a problem for the Waze app because the routing server gives your mobile app a list of node ids, but the app needs to tell you which segments to drive on. If there are two ways to get from one node to the next without going through any other nodes, then the Waze app might just have to guess.

Source: https://wiki.waze.com/wiki/Junction_Sty ... ment_loops

Is there a newer version of this guide?
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2018.11.10 (BETA)

Postby berestovskyy » Mon Jan 28, 2019 6:11 pm

theMadcabbie wrote:Is it possible to validate the correct abbreviations for Road names i.e Rd and St etc as per our UK list?

Sure, it is possible and many countries has that feature as a part of a localization pack or as a part of i18n repo of Validator: https://github.com/WMEValidator/i18n

I (or other guys here) will help with any technical difficulties or questions.
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2018.11.10 (BETA)

Postby berestovskyy » Tue Feb 26, 2019 6:12 pm

Hi guys,
Sorry, it seems I don't have editable areas anymore :lol:

Just to make sure. Could you please confirm it's Validator by:
1. Disabling all the scripts
2. Checking if WME works fine
3. Then by enabling just Validator
4. And confirming WME does not work anymore?

Thanks in advance!
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby berestovskyy » Tue Feb 26, 2019 9:12 pm

Thanks,
The update has been published.

Could you please confirm it fixes the issue for you?
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2018.09.15 (BETA)

Postby berestovskyy » Wed Mar 06, 2019 9:24 pm

berestovskyy wrote:
Nazride wrote:error on : Noeud A: inutil (mode lent) (#36)
or here

https://www.waze.com/fr/editor/?zoom=7& ... =343409108

Same issues as with lg1992 report: WME sometimes does not report nodes as "partial". We will try to workaround it in the code.


Hey guys,
The issues with "ghost" (disappearing) Validator reports due to the missing attribute "partial" is fixed in the latest WME Beta. So it will be available for everyone soon ;)

Sorry, it took quite a time. But still I'm really impressed Waze guys managed to fix it!
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby berestovskyy » Thu Mar 21, 2019 5:48 am

LysdexiaEht wrote:What kind of steps could I take to troubleshoot this further?

Thanks for reporting.

Could you please check the JavaScript console (View->Developer->JavaScript Console) if there are any logs or errors from Validator or WME...
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby berestovskyy » Fri Apr 05, 2019 5:28 am

If there are no errors in between those logs, it’s normal...

Which Waze server do you use? Or which country you are from?
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

Re: [Script] WME Validator 2019.04.11 (BETA)

Postby berestovskyy » Thu Apr 11, 2019 10:21 pm

Hi,
After a few days of trying to reproduce the issue, finally I was able to reproduce and fix it today.

Thanks for reporting and sorry for the delay.
berestovskyy
 
Posts: 897
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 327 times
Been thanked: 821 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: jm6087, JustinS83, mudge42, Mythdraug