Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by crazycaveman
I'm running into a strange issue with user-defined checks, but I'm not sure if it's due to the order the checks are run. For some reason, when Waze did the base map import, several roads in South Carolina have been assigned to the state of Georgia. I've cleaned up most of these, but there are a few stragglers, so I entered the regex /Georgia/ with the template ${state}, ran the report, and got 18 hits. I then thought, "what if there are others that should be set to South Carolina that currently aren't?" So I changed the regex to !/South Carolina/, ran the report, and got none (using the exact same view)! I ran the initial report (Georgia) with duplicates and non-editables excluded and ran the second report with non-editables excluded and with and without duplicates, but got similar results (as stated above). Is there a reason one regex works properly while the other one doesn't? Am I missing something with regards to negated regex's?
crazycaveman
US Waze Champs
US Waze Champs
Posts: 843
Has thanked: 229 times
Been thanked: 441 times

Post by crazycaveman
pumrum wrote:If you are stuck, try resetting the validator. Make sure "Exclude non-editable segments" is not checked after your reset, and set the custom filter again. Once you have verified manually that it is highlighting as expected, you can run a report. If you want to only see the custom filter results, set the "Reported as" filter to 128 (green) or 129 (blue) or 128,129 (green and blue)
Thanks for the suggestion! I tested the regex at a border and it seemed fine, but didn't know you could run a report with just the custom checks. Doing that seemed to find all of them correctly.
berestovskyy wrote:
crazycaveman wrote:Am I missing something with regards to negated regex's?
The report is cleared automatically once you change either a template or a regexp field. I guess you changed your custom check after the scan has been completed. This is my best guess. A permalink would help.
I ran a report, changed my custom check, and then ran it again, assuming, as you've verified, that the report would clear itself. I'll try running the report again while manually clearing it out. This is the area I'm running the report in, if you want to try it yourself.
crazycaveman
US Waze Champs
US Waze Champs
Posts: 843
Has thanked: 229 times
Been thanked: 441 times

Post by coontex
Nearly impossible to see what needs to be corrected and what does not. Have to click on every segment.


Sent from my iPhone using Tapatalk
coontex
Map Raider
Map Raider
Posts: 943
Has thanked: 200 times
Been thanked: 272 times

Post by coontex
Thank you for the fast update.


Sent from my iPhone using Tapatalk
coontex
Map Raider
Map Raider
Posts: 943
Has thanked: 200 times
Been thanked: 272 times

Post by crayzee
I 'd vote for tab also. Scrolling down for URC or URO+ is not convinient.

Other solution might be expanding aand colapsing Validator with button on main panel.
crayzee
Country Manager
Country Manager
Posts: 1938
Has thanked: 318 times
Been thanked: 197 times
https://s.waze.tools/s0075.png
CM : Israel, Montenegro
AM: Rishon LeZion@Israel
פרמלינק - Permalink
נא לסמן https://www.tinyurl.com/wazev לצורך דיווח סיום טיפול.

Post by crayzee
Working for me on Chrome (WME beta)
crayzee
Country Manager
Country Manager
Posts: 1938
Has thanked: 318 times
Been thanked: 197 times
https://s.waze.tools/s0075.png
CM : Israel, Montenegro
AM: Rishon LeZion@Israel
פרמלינק - Permalink
נא לסמן https://www.tinyurl.com/wazev לצורך דיווח סיום טיפול.

Post by Corentin-48
Wait a new release, a lot of scripts are not working because of the new version of the editor. They'll be update when the authors can.
So wait and see ! :D
Corentin-48
Country Manager
Country Manager
Posts: 686
Has thanked: 95 times
Been thanked: 114 times
https://s.waze.tools/c5.pnghttps://s.waze.tools/beta.pnghttps://s.waze.tools/betc.png

France Country Manager
France Regional Manager : Occitanie
Andorra Area Manager
Vadrouille quotidiennement entre le 92 et le 78.

La communauté Waze France est sur Discord. Rejoignez-nous !

Post by Corentin-48
Alerts are in Toolbox (U-turn, RevCon, Loop, Dead End, ...) & highlight segments are in Validator (blue, yellow & red)
Corentin-48
Country Manager
Country Manager
Posts: 686
Has thanked: 95 times
Been thanked: 114 times
https://s.waze.tools/c5.pnghttps://s.waze.tools/beta.pnghttps://s.waze.tools/betc.png

France Country Manager
France Regional Manager : Occitanie
Andorra Area Manager
Vadrouille quotidiennement entre le 92 et le 78.

La communauté Waze France est sur Discord. Rejoignez-nous !

Post by Corentin-48
Thank you berestovskyy for the update!! :D

I found a bug, after a scan zoom 0, zoom 6, ... I click on the results and it's open & close quickly the results tab. I don't have the time to see the results.
I don't know if i'm the only one.

I'm using Firefox 49.0.2 EME-Free 64 Bits on Win 10
Corentin-48
Country Manager
Country Manager
Posts: 686
Has thanked: 95 times
Been thanked: 114 times
https://s.waze.tools/c5.pnghttps://s.waze.tools/beta.pnghttps://s.waze.tools/betc.png

France Country Manager
France Regional Manager : Occitanie
Andorra Area Manager
Vadrouille quotidiennement entre le 92 et le 78.

La communauté Waze France est sur Discord. Rejoignez-nous !

Post by Coloradotom123
shmupi wrote:
Coloradotom123 wrote:
shmupi wrote:
Indeed.

I have informed the creator of the script about the latest changes of the WME and that the validator script is not working since the latest change.

Thanks,
Shmupi
Has the creator responded to you. Everything that I have read has said the creator is no longer active?
Not yet...

:(
Well that's a bummer I hope that someone is actively working on it. Thanks for responding.
Coloradotom123
Posts: 5
Has thanked: 11 times