[Script] WME Validator v2021.3.5 (+ PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby Coloradotom123 » Tue Dec 27, 2016 5:05 pm

shmupi wrote:
Coloradotom123 wrote:
shmupi wrote:
Indeed.

I have informed the creator of the script about the latest changes of the WME and that the validator script is not working since the latest change.

Thanks,
Shmupi

Has the creator responded to you. Everything that I have read has said the creator is no longer active?


Not yet...

:(

Well that's a bummer I hope that someone is actively working on it. Thanks for responding.
Coloradotom123
 
Posts: 5
Joined: Wed Sep 21, 2016 12:16 am
Location: Pueblo, CO. USA
Has thanked: 13 times
Been thanked: 0 time

Re: [Script] WME Validator 1.0.3 / 04.08.2014

Postby coontex » Sun Aug 24, 2014 2:42 pm

Nearly impossible to see what needs to be corrected and what does not. Have to click on every segment.


Sent from my iPhone using Tapatalk
coontex
Map Raider
Map Raider
 
Posts: 943
Joined: Fri Jan 17, 2014 3:01 am
Location: Opelousas, La
Has thanked: 200 times
Been thanked: 272 times

Re: [Script] WME Validator 1.0.4 / 24.08.2014

Postby coontex » Sun Aug 24, 2014 4:43 pm

Thank you for the fast update.


Sent from my iPhone using Tapatalk
coontex
Map Raider
Map Raider
 
Posts: 943
Joined: Fri Jan 17, 2014 3:01 am
Location: Opelousas, La
Has thanked: 200 times
Been thanked: 272 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby Corentin-48 » Tue May 24, 2016 10:50 am

Wait a new release, a lot of scripts are not working because of the new version of the editor. They'll be update when the authors can.
So wait and see ! :D
[ img ][ img ][ img ]

France Country Manager
France Regional Manager : Occitanie
Andorra Area Manager
Vadrouille quotidiennement entre le 92 et le 78.

La communauté Waze France est sur Discord.Rejoignez-nous !
Corentin-48
Country Manager
Country Manager
 
Posts: 678
Joined: Thu Jan 22, 2015 7:04 pm
Location: Dans un bartàs
Has thanked: 117 times
Been thanked: 115 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby Corentin-48 » Thu May 26, 2016 12:00 pm

Alerts are in Toolbox (U-turn, RevCon, Loop, Dead End, ...) & highlight segments are in Validator (blue, yellow & red)
[ img ][ img ][ img ]

France Country Manager
France Regional Manager : Occitanie
Andorra Area Manager
Vadrouille quotidiennement entre le 92 et le 78.

La communauté Waze France est sur Discord.Rejoignez-nous !
Corentin-48
Country Manager
Country Manager
 
Posts: 678
Joined: Thu Jan 22, 2015 7:04 pm
Location: Dans un bartàs
Has thanked: 117 times
Been thanked: 115 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby Corentin-48 » Thu Nov 03, 2016 6:17 pm

Thank you berestovskyy for the update!! :D

I found a bug, after a scan zoom 0, zoom 6, ... I click on the results and it's open & close quickly the results tab. I don't have the time to see the results.
I don't know if i'm the only one.

I'm using Firefox 49.0.2 EME-Free 64 Bits on Win 10
[ img ][ img ][ img ]

France Country Manager
France Regional Manager : Occitanie
Andorra Area Manager
Vadrouille quotidiennement entre le 92 et le 78.

La communauté Waze France est sur Discord.Rejoignez-nous !
Corentin-48
Country Manager
Country Manager
 
Posts: 678
Joined: Thu Jan 22, 2015 7:04 pm
Location: Dans un bartàs
Has thanked: 117 times
Been thanked: 115 times

Re: [Script] WME Validator 1.1.10 / 05.11.2015

Postby crayzee » Fri Nov 06, 2015 7:02 am

I 'd vote for tab also. Scrolling down for URC or URO+ is not convinient.

Other solution might be expanding aand colapsing Validator with button on main panel.
[ img ][ img ][ img ][ img ][ img ]
CM : Israel, Montenegro
AM: Rishon LeZion@Israel
פרמלינק - Permalink
נא לסמן [ img ] לצורך דיווח סיום טיפול.
crayzee
Country Manager
Country Manager
 
Posts: 1927
Joined: Fri Apr 10, 2009 6:01 am
Has thanked: 397 times
Been thanked: 238 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby crayzee » Thu Mar 31, 2016 4:53 am

Working for me on Chrome (WME beta)
[ img ][ img ][ img ][ img ][ img ]
CM : Israel, Montenegro
AM: Rishon LeZion@Israel
פרמלינק - Permalink
נא לסמן [ img ] לצורך דיווח סיום טיפול.
crayzee
Country Manager
Country Manager
 
Posts: 1927
Joined: Fri Apr 10, 2009 6:01 am
Has thanked: 397 times
Been thanked: 238 times

Re: [Script] WME Validator 0.9.9 (BETA) / 27.04.2014

Postby crazycaveman » Wed Apr 30, 2014 6:55 pm

I'm running into a strange issue with user-defined checks, but I'm not sure if it's due to the order the checks are run. For some reason, when Waze did the base map import, several roads in South Carolina have been assigned to the state of Georgia. I've cleaned up most of these, but there are a few stragglers, so I entered the regex /Georgia/ with the template ${state}, ran the report, and got 18 hits. I then thought, "what if there are others that should be set to South Carolina that currently aren't?" So I changed the regex to !/South Carolina/, ran the report, and got none (using the exact same view)! I ran the initial report (Georgia) with duplicates and non-editables excluded and ran the second report with non-editables excluded and with and without duplicates, but got similar results (as stated above). Is there a reason one regex works properly while the other one doesn't? Am I missing something with regards to negated regex's?
[ img ][ img ] [ img ][ img ][ img ]
ARC: South Atlantic Region
crazycaveman
US Waze Champs
US Waze Champs
 
Posts: 833
Joined: Fri Sep 03, 2010 1:48 am
Location: Rock Hill, SC, USA
Has thanked: 353 times
Been thanked: 523 times

Re: [Script] WME Validator 0.9.9 (BETA) / 27.04.2014

Postby crazycaveman » Thu May 01, 2014 1:18 pm

pumrum wrote:If you are stuck, try resetting the validator. Make sure "Exclude non-editable segments" is not checked after your reset, and set the custom filter again. Once you have verified manually that it is highlighting as expected, you can run a report. If you want to only see the custom filter results, set the "Reported as" filter to 128 (green) or 129 (blue) or 128,129 (green and blue)

Thanks for the suggestion! I tested the regex at a border and it seemed fine, but didn't know you could run a report with just the custom checks. Doing that seemed to find all of them correctly.

berestovskyy wrote:
crazycaveman wrote:Am I missing something with regards to negated regex's?

The report is cleared automatically once you change either a template or a regexp field. I guess you changed your custom check after the scan has been completed. This is my best guess. A permalink would help.

I ran a report, changed my custom check, and then ran it again, assuming, as you've verified, that the report would clear itself. I'll try running the report again while manually clearing it out. This is the area I'm running the report in, if you want to try it yourself.
[ img ][ img ] [ img ][ img ][ img ]
ARC: South Atlantic Region
crazycaveman
US Waze Champs
US Waze Champs
 
Posts: 833
Joined: Fri Sep 03, 2010 1:48 am
Location: Rock Hill, SC, USA
Has thanked: 353 times
Been thanked: 523 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: alexs001, ldriveskier, Mapman44, Skulllzzcode