Routing errors in London

Image

Moderators: Unholy, Timbones

Re: Routing errors in London

Postby Twister-UK » Wed Dec 04, 2013 7:56 pm

Based on the results logged so far, it appears things are still being rolled around within the server room...
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Sat Dec 07, 2013 5:33 pm

Don't know if it was an error in the route tester or with the routing server, but for around an hour or so from half 10 this morning I wasn't getting any responses logged from the server. I killed the tester and then restarted it just before 1pm, and since then it's been consistently getting results where both routes aren't reaching the required endpoint which isn't something I've seen occur for such an extended period of time. So it looks as if *something* is going on with the server, and fingers crossed it's intentional rather than just another snafu.
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Fri Jan 03, 2014 11:29 pm

As requested by David, I've uploaded some further test results obtained in early December... Data was logged between midday on the 7th until early morning on the 10th.

On the 7th and 8th routing results were pretty much OK, as expected for a weekend. On the 9th the usual pattern emerged, with routing failing completely during the morning and evening rush hours. Logging was stopped on the 10th before any rush-hour effects could creep into the data for that day.

Raw data for this test: http://chizzum.com/lmr/test5.zip


Notes on the CSV file layout...

The first 4 columns contain data common to all routes returned in the request:
Columns 1&2 - Date/time of request
Column 3 - Elapsed time (ms) between submitting request and receiving response
Column 4 - 0 if any routes were returned, 1 if no routes were returned

Each returned route then adds 5 columns as follows:
Column 5 - 0 if route reached the exact expected endpoint, 1 if it did not (no matter how close it got)
Columns 6&7 - actual endpoint coordinates
Column 8 - route distance
Column 9 - route time
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 06, 2014 8:06 am

A shade over 8 hours into the start of a new logging session, and so far everything is proceeding as usual. Unfortunately. One of these days I'll check the results and see the routing server hasn't fallen over at the start of the morning rush hour, but that day isn't today... Oh well, it'll all get fixed "soon", right.
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 06, 2014 12:00 pm

It's the same test route as originally requested by Waze. Haven't cross-referenced the yellow brick segment list against the raw route data yet, will have a look at that when I get a chance...
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 13, 2014 1:06 pm

Twister-UK wrote:A shade over 8 hours into the start of a new logging session, and so far everything is proceeding as usual. Unfortunately. One of these days I'll check the results and see the routing server hasn't fallen over at the start of the morning rush hour, but that day isn't today... Oh well, it'll all get fixed "soon", right.


I now have a full weeks-worth of data logged for this test route, and whilst a full summary/data upload will have to wait until I've got more free time than I had over breakfast this morning, the TL:DR version is both simple and unsurprising - the routing server performance appears to be no better now than during any of the previous test runs...
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 13, 2014 11:50 pm

The results from last week have now been broken down into daily graphical summaries.

The two routes returned are graphed out as red = fastest and blue = shortest. Where the graphs have a yellow background, the server failed to return any routes. The horizontal axes are marked off in hours.

The "Route Time" and "Route Distance" graphs show the calculated times and distances for the returned routes.

The "Server Response Time" graph shows how long it took the server to respond to the routing request.


Monday:
Image
Image
Image

Tuesday:
Image
Image
Image

Wednesday:
Image
Image
Image

Thursday:
Image
Image
Image

Friday:
Image
Image
Image

Saturday:
Image
Image
Image

Sunday:
Image
Image
Image


Raw data for this test: http://chizzum.com/lmr/test6.zip (427MB archive)
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Thu Jan 30, 2014 7:08 am

Almost halfway through this logging session, and plots of the Monday-Wednesday results are available above...I'm not saying this set of results is *identical* to those recorded last time, merely that they're sufficiently similar to make me question whether it's worth the time and effort to generate new daily plots that you'd need to compare side by side with the previous set in order to spot any real changes.

So as has been hinted at by the posts above, seems like as far as London routing is concerned, it remains situation normal, all f'd up - unsurprise, unsurprise. Unless there are any radical changes in routing performance over the next few days that would justify doing some daily plots, I think I'll just wait for the full weeks-worth of data to be collected and then do a few comparison plots to show how similar the two sets of data really are.
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Sat Feb 01, 2014 1:49 pm

With all the weekday results now recorded from this run, time for a couple of quick comparison plots...

First up, routing failures. These are the regions in the previous daily plots that were shaded in yellow, here the previous run is shown in red and the current run shown in blue:

Image

Spot the difference? Other than Friday morning, where this time around the server managed not to fall over at all, the rush hour responses throughout the rest of the week are rather similar.


And now server response times. Again, the previous run is shown in red, the current run in blue:

Image

Ignoring the short-term variations and looking just at the longer-term shapes of these two plots, there's again little to differentiate them.


So as far as I can see, this week has been business as usual for the routing server, despite whatever changes Waze have made. Raw data will be uploaded for them to ponder over at some point on Monday once the remainder of the weekend results have been captured. Let's hope they can put it to some use and figure out another server tweak that results in some visible improvements this time.
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

Re: Routing errors in London

Postby Twister-UK » Mon Feb 03, 2014 10:26 pm

Raw data for last week's test will shortly be available at http://chizzum.com/lmr/test7.zip (404MB archive)
L4 AM for NW London and Shetland Islands - HTC One M8/Android 5.0.1
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Image
Twister-UK
Area Manager
Area Manager
 
Posts: 1409
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 162 times
Been thanked: 925 times

PreviousNext

Return to United Kingdom

Who is online

Users browsing this forum: No registered users