Routing errors in London

Image

Moderators: Unholy, Timbones

Re: Routing errors in London

Postby winelight » Tue Mar 25, 2014 11:23 am

Just to say that I have now experienced this myself. Well it wasn't really in London, returning from Croydon area to Watford area, so all I wanted was a route round the M25. But just got nothing from Waze until a good 30 minutes into the journey. Evening rush hour.
winelight
 
Posts: 402
Joined: Fri Feb 17, 2012 10:42 am
Has thanked: 24 times
Been thanked: 14 times

Re: Routing errors in London

Postby Twister-UK » Sat Apr 19, 2014 10:27 am

dknight212 wrote:Yes I'm afraid Waze are still searching for a fix.


But as they're using their own search routines, they only get results in the evenings and weekends...
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Wed Feb 26, 2014 12:45 pm

Captured some data between 01:00 and 22:00 yesterday, which continues the trend of showing absolutely no improvement whatsoever over earlier tests - routing failed completely during the morning (07:19-09:05) and evening (16:34-18:30) rush hours.
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Wed Feb 19, 2014 5:40 pm

Timbones wrote:I'm tracking a handful of routes across London, and they're all failing during the morning rush hour(s).


And the trusty old north-south route I've been monitoring in previous tests is also failing during this evenings rush hour - Error: 503|Could not find a route...
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Mon Feb 03, 2014 10:26 pm

Raw data for last week's test will shortly be available at http://chizzum.com/lmr/test7.zip (404MB archive)
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Sat Feb 01, 2014 1:49 pm

With all the weekday results now recorded from this run, time for a couple of quick comparison plots...

First up, routing failures. These are the regions in the previous daily plots that were shaded in yellow, here the previous run is shown in red and the current run shown in blue:

Image

Spot the difference? Other than Friday morning, where this time around the server managed not to fall over at all, the rush hour responses throughout the rest of the week are rather similar.


And now server response times. Again, the previous run is shown in red, the current run in blue:

Image

Ignoring the short-term variations and looking just at the longer-term shapes of these two plots, there's again little to differentiate them.


So as far as I can see, this week has been business as usual for the routing server, despite whatever changes Waze have made. Raw data will be uploaded for them to ponder over at some point on Monday once the remainder of the weekend results have been captured. Let's hope they can put it to some use and figure out another server tweak that results in some visible improvements this time.
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Thu Jan 30, 2014 7:08 am

Almost halfway through this logging session, and plots of the Monday-Wednesday results are available above...I'm not saying this set of results is *identical* to those recorded last time, merely that they're sufficiently similar to make me question whether it's worth the time and effort to generate new daily plots that you'd need to compare side by side with the previous set in order to spot any real changes.

So as has been hinted at by the posts above, seems like as far as London routing is concerned, it remains situation normal, all f'd up - unsurprise, unsurprise. Unless there are any radical changes in routing performance over the next few days that would justify doing some daily plots, I think I'll just wait for the full weeks-worth of data to be collected and then do a few comparison plots to show how similar the two sets of data really are.
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 13, 2014 11:50 pm

The results from last week have now been broken down into daily graphical summaries.

The two routes returned are graphed out as red = fastest and blue = shortest. Where the graphs have a yellow background, the server failed to return any routes. The horizontal axes are marked off in hours.

The "Route Time" and "Route Distance" graphs show the calculated times and distances for the returned routes.

The "Server Response Time" graph shows how long it took the server to respond to the routing request.


Monday:
Image
Image
Image

Tuesday:
Image
Image
Image

Wednesday:
Image
Image
Image

Thursday:
Image
Image
Image

Friday:
Image
Image
Image

Saturday:
Image
Image
Image

Sunday:
Image
Image
Image


Raw data for this test: http://chizzum.com/lmr/test6.zip (427MB archive)
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 13, 2014 1:06 pm

Twister-UK wrote:A shade over 8 hours into the start of a new logging session, and so far everything is proceeding as usual. Unfortunately. One of these days I'll check the results and see the routing server hasn't fallen over at the start of the morning rush hour, but that day isn't today... Oh well, it'll all get fixed "soon", right.


I now have a full weeks-worth of data logged for this test route, and whilst a full summary/data upload will have to wait until I've got more free time than I had over breakfast this morning, the TL:DR version is both simple and unsurprising - the routing server performance appears to be no better now than during any of the previous test runs...
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

Re: Routing errors in London

Postby Twister-UK » Mon Jan 06, 2014 12:00 pm

It's the same test route as originally requested by Waze. Haven't cross-referenced the yellow brick segment list against the raw route data yet, will have a look at that when I get a chance...
Chris (not to be confused with Chris or Chris...)
L4 AM SE England & Shetland Islands / WME Beta Tester / Script Writer
WME/Livemap enhancement scripts @ GreasyFork and Chrome Web Store
Twister-UK
Beta tester
Beta tester
 
Posts: 5807
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 439 times
Been thanked: 2593 times

PreviousNext

Return to United Kingdom

Who is online

Users browsing this forum: Google [Bot]