The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.
Post by tecwzrdmf
A permalink and the type of landmark you are trying to add would be helpful.
tecwzrdmf
Posts: 62
Has thanked: 19 times
Been thanked: 5 times

Post by whoyaposan
i'm a level 1 editor and I cannot add a landmark, my landmark has 4 nodes, and they are not overlaping, it's really frustrating because i drove all the way here and I can't add it. I'm in Costa Rica so i have no idea what satellite I'm using, would appreciate some help thx!
whoyaposan
Posts: 1

Post by juankx
whoyaposan wrote:i'm a level 1 editor and I cannot add a landmark, my landmark has 4 nodes, and they are not overlaping, it's really frustrating because i drove all the way here and I can't add it. I'm in Costa Rica so i have no idea what satellite I'm using, would appreciate some help thx!
Hello whoyaposan, do you live in Costa Rica? I'm part of the Costa Rica team and we are glad you want to contribute with our map. What kind of error are you receiving when you try to include the new landmark?

You could get local guidance and help here: viewforum.php?f=501
juankx
Waze Global Champs
Waze Global Champs
Posts: 1851
Has thanked: 123 times
Been thanked: 528 times

Post by ply8808
My experiences in the past few days with landmarks (places and points) have been intermittent with save issues, there are times when no issues are encountered and others that the save error displays and upon backing out of saves and refreshing the changes are present.
As yet I have been unable to isolate the issue to a time of day, area or type of landmark.
ply8808
Waze Global Champs
Waze Global Champs
Posts: 1327
Has thanked: 1280 times
Been thanked: 930 times
Global Champ
Local Champ - USA
HD riding wazer, Arizona.
iPhone 7, iOS 13.3.1