[Script] WME Junction Angle Info

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderator: Unholy

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [script] WME Junction Angle Info

Postby FZ69617 » Tue May 19, 2015 8:17 pm

Arnoniem wrote:So, any chance of getting a uturn colour? :)

The feature is already developed and is waiting for merge into the official GH repo by @milkboy.

We'll likely use a violet color for the U-turn instructions in a default colors scheme:
Image

If you are interested you may try a JAI development version that supports it.
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Wed May 20, 2015 11:50 am

Arnoniem wrote:just noticed a 168.6 angle gets purple as well.
But on the angles I've done tests with, (without checking the first decimal), a 169 angle still gave a turn left. A 170 degr was a uturn prompt.

The u-turn angle in use currently is 168.24 with a "gray zone" ±0.2 degrees.
These values are based on my multiple map experiments performed last week.

The recent series of these experiments is still on the map and all examples matches the current values:
Image
The anomalies - which were a basis for a gray (in fact yellow ;) ) zone approximation - has been observed so far just for the two unselected examples in the above picture.

Could you post the permalinks to examples you mention that violates current rules?
Together we can find better approximation of a u-turn and/or a gray zone angles.
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Wed May 20, 2015 12:35 pm

Arnoniem wrote:Did you actually navigate and get a uturn prompt at 168.5 degr?

Sure, see the route going through this segment with a u-turn prompt at 168.47 degrees:
Image
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Thu May 21, 2015 5:05 pm

voludu2 wrote:I found a case where JAI does not reach the same conclusion on BC as the mobile app or route checker:

https://www.waze.com/editor/?env=usa&lo ... 8,75487051

JAI does not catch on to this.

Thanks for finding this.

You may try another JAI development version that correctly handles this case.

The changes in the routing instruction estimation algorithm still requires further testing (all implemented conditions are rather my guessing than knowledge :) ), but all the cases tested so far looks promising. :D
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Fri May 22, 2015 8:09 am

bz2012 wrote:After trying the latest development version, I found wild rapid 'scrolling' when attempting to click and drag to move the view. :(

I'm not aware of any changes in JAI that could cause such a strange behaviour.
I personally experienced "rapid scrolling" even without any addon enabled, thus maybe it just coincidentally happened to you after installing JAI.

bz2012 wrote:So, turned it off and turned regular JAI on, F5 to load, and all works normally now so, there may be a conflict of some kind.

Did you try F5 having only JAI development version enabled?
If the problem persists please describe closer your environment (the browser version, what other addons are used etc.).
I'm currently using latest JAI development version and it works without any problems in Chrome and Firefox with over 20 other WME addons enabled.
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Fri May 22, 2015 2:18 pm

bz2012 wrote:Can't get it to act up this morning. :(

I guess, then, that everything is working properly. So why are you sad? :)
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Thu May 28, 2015 1:32 pm

Arnoniem wrote:I just noticed one of my tests showing a "turn left" at the 168.45 angle. It could be the bug that gives a left instead of uturn, but I don't think so, since the livemap gives the same result. Have a look here:
https://www.waze.com/editor/?env=row&lo ... ,274372422

Thanks for finding this another anomaly.
Foreseeing other unknown cases the gray zone has been extended into 1 degree (i.e. 168.24 ± 0.5).

Arnoniem wrote:Oh, and i noticed another thing:
On a 2 segment uturn at 170degr+, JAI gives a Best continuation, however the actual instruction is also a uturn:
https://www.waze.com/editor/?env=row&lo ... =280755690

Hmm, another interesting change to the algorithm. Previously, no instruction was the only option in case of just one s-out.

This JAI development version fixes the problems.

Thank you Arnoniem for the reports.
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby FZ69617 » Tue Jun 16, 2015 7:33 pm

For those who would like to try a new JAI feature called "disallowed U-turns indicator" there is the latest development version available supporting this:
https://github.com/FZ69617/WME-ja/raw/m ... le.user.js

The indicator is displayed only for 15m or less long segments with disallowed U-turn as documented in U-turn avoidance conditions in Wiki.

Example:
Image
Here the yellow bubbles displayed next to the green ones indicates disallowed U-turns.

Hope incoming official JAI version will also include this new feature.
FZ69617
Waze Local Champs
Waze Local Champs
 
Posts: 609
Joined: Fri Jul 25, 2014 9:29 am
Location: Zielona Góra, Poland
Has thanked: 58 times
Been thanked: 201 times

Re: [script] WME Junction Angle Info

Postby GizmoGuy411 » Wed Feb 19, 2014 12:19 am

I've had no luck getting JAI to work.

I've tried Alan's patched version and now the myriades version and still nothing. Both extensions seem to install ok with no errors. Neither version shows in the Layers drop-down either.

Also tried with it being the ONLY extension running, and cleared the Chrome cache.

Anyone else having issues getting it to run?

(As a cautionary side note. I initially could not get the script to install using Notepad++ to create the file. On my Windows 7 system, I had to use Notepad. Notepad++ may require a different setting to work.)

I'll also try to post this in the French forum.
ImageImageImageImage

Global Champ
U.S. CM
U.S. Great Lakes RC: IL, IN, MI, OH, WI
AM: NW OH, NE IN, SE MI
Wiki Profile
Verizon: Galaxy S4 w/ Android 4.4.2 & iPad "3" w/ iOS 8.2.0
GizmoGuy411
Global Champ Mentor
Global Champ Mentor
 
Posts: 1325
Joined: Wed Oct 13, 2010 3:14 am
Location: NW Ohio, SE Michigan, NW Indiana tri-state area
Has thanked: 411 times
Been thanked: 273 times

Re: [script] WME Junction Angle Info

Postby GizmoGuy411 » Wed Feb 19, 2014 6:44 pm

AlanOfTheBerg wrote:
GizmoGuy411 wrote:I've had no luck getting JAI to work.

You are saving it as .user.js right? And developer mode is enabled?


Yes to both. And same result for your version and myriades version too. I have not tried the other version prior to yours yet.

Without the xxxx.user.js I don't think they even would have installed. They both displayed in the Chrome Extension page as installed and enabled.

For both I deleted them, cleared cache, closed Chrome and then reopened it before installing.
ImageImageImageImage

Global Champ
U.S. CM
U.S. Great Lakes RC: IL, IN, MI, OH, WI
AM: NW OH, NE IN, SE MI
Wiki Profile
Verizon: Galaxy S4 w/ Android 4.4.2 & iPad "3" w/ iOS 8.2.0
GizmoGuy411
Global Champ Mentor
Global Champ Mentor
 
Posts: 1325
Joined: Wed Oct 13, 2010 3:14 am
Location: NW Ohio, SE Michigan, NW Indiana tri-state area
Has thanked: 411 times
Been thanked: 273 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: No registered users