[Script] WME Color Highlights - 1.98 Dec 2014

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderator: Unholy

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Color Highlights - 1.91 July 2014

Postby SuperDave1426 » Wed Oct 15, 2014 7:25 pm

That would be awesome! :D
ImageImageImageImage
State Manager: Nevada, USA
Area Manager: Northern CA; Greater Los Angeles area, CA
Editor Guide Best Editing Practices Editor Quick-start
Places Guidelines Nevada Wiki
SuperDave1426
State Manager
State Manager
 
Posts: 634
Joined: Wed Oct 16, 2013 5:27 pm
Location: Nevada, USA
Has thanked: 58 times
Been thanked: 147 times

Re: [Script] WME Color Highlights - 1.94 Oct 2014

Postby SuperDave1426 » Tue Dec 02, 2014 7:19 pm

I don't know if this has been brought to anyone's attention yet, but I'm finding that Color Highlights is causing a lot of really bad lag in WME. When I run with it active, moving the map around lags, updating roads lag, everything just seems to lag rather badly.

I've tried both the Chrome store version 1.94 as well as the userscript version 1.97 for Tampermonkey, and they both cause equal amounts of WME lag. I hope this is something which can be fixed; I really like and use the things it highlights....
ImageImageImageImage
State Manager: Nevada, USA
Area Manager: Northern CA; Greater Los Angeles area, CA
Editor Guide Best Editing Practices Editor Quick-start
Places Guidelines Nevada Wiki
SuperDave1426
State Manager
State Manager
 
Posts: 634
Joined: Wed Oct 16, 2013 5:27 pm
Location: Nevada, USA
Has thanked: 58 times
Been thanked: 147 times

Re: [Script] WME Color Highlights - 1.94 Oct 2014

Postby SuperDave1426 » Tue Dec 02, 2014 8:57 pm

I don't know - all of them? :D I've heard comments in the WME chat from a number of other people who have traced down really bad lag to Highlights - they've all said that disabling the addon gets rid of most of the lag. I finally tried it and was amazed by how much faster I could scroll around and move roads and so on.

I'll try turning off place highlighting to start and see if that has any impact. Will progress from there and will let you know if/what I find.

Edit: Ok, I've had a chance to play around with it a bit. I still see lag when the plugin is enabled, but it does seem to be considerably worse when place highlighting is turned on. When I turn it off, I still seem to get bits of lag here and there, but not to the extent that there is when place highlighting it turned on. I'll continue to observe and play with it and will let you know if I notice anything else.
ImageImageImageImage
State Manager: Nevada, USA
Area Manager: Northern CA; Greater Los Angeles area, CA
Editor Guide Best Editing Practices Editor Quick-start
Places Guidelines Nevada Wiki
SuperDave1426
State Manager
State Manager
 
Posts: 634
Joined: Wed Oct 16, 2013 5:27 pm
Location: Nevada, USA
Has thanked: 58 times
Been thanked: 147 times

Re: [Script] WME Color Highlights - 1.94 Oct 2014

Postby SuperDave1426 » Wed Dec 10, 2014 1:18 am

Sounds like a useful new feature for places. I just wish that turning on "highlight places" didn't slow down my WME session so much....

Is it going to highlight points as well? We get an awful lot of those that aren't complete from submissions via the app. Since the app doesn't submit area places, we really need a way to know about incomplete points as well...
ImageImageImageImage
State Manager: Nevada, USA
Area Manager: Northern CA; Greater Los Angeles area, CA
Editor Guide Best Editing Practices Editor Quick-start
Places Guidelines Nevada Wiki
SuperDave1426
State Manager
State Manager
 
Posts: 634
Joined: Wed Oct 16, 2013 5:27 pm
Location: Nevada, USA
Has thanked: 58 times
Been thanked: 147 times

Re: [Script] WME Color Highlights - 1.94 Oct 2014

Postby SuperDave1426 » Thu Dec 11, 2014 10:02 pm

Out of curiosity, what is the method by which the highlighter decides that a place (area or place) is "incomplete?" Lack of street address information? Something/anything else?
ImageImageImageImage
State Manager: Nevada, USA
Area Manager: Northern CA; Greater Los Angeles area, CA
Editor Guide Best Editing Practices Editor Quick-start
Places Guidelines Nevada Wiki
SuperDave1426
State Manager
State Manager
 
Posts: 634
Joined: Wed Oct 16, 2013 5:27 pm
Location: Nevada, USA
Has thanked: 58 times
Been thanked: 147 times

Re: [Script] WME Color Highlights - 1.98 Dec 2014

Postby SuperDave1426 » Fri Feb 06, 2015 7:29 pm

JJohnston84 wrote:Feature request: A separate place highlight option / unique color that highlights any places last edited by a username starting with "ign_" (when place highlights are turned on, of course).

Image Given that the IGN editors just blanket-approve place updates without bothering to add additional information (street address, business website, etc.) or ensure that the picture submitted is acceptable and useful, having them approve a place before one of us editors can get to it can be problematic.

Having a way to show places last edited by ign_* would at least let us know they're there, which then gives us an opportunity to make the place more useful....

Any chance this can be added in the future?
ImageImageImageImage
State Manager: Nevada, USA
Area Manager: Northern CA; Greater Los Angeles area, CA
Editor Guide Best Editing Practices Editor Quick-start
Places Guidelines Nevada Wiki
SuperDave1426
State Manager
State Manager
 
Posts: 634
Joined: Wed Oct 16, 2013 5:27 pm
Location: Nevada, USA
Has thanked: 58 times
Been thanked: 147 times

Re: [Script] Highlights for Segments & Landmarks - v1.6 Feb

Postby svx-biker » Fri Feb 22, 2013 2:48 pm

Suddenly the directionality one-way doesn't show if the segments isn't marked. Is this a bug with the highlighter or do other editors have the same problem?
svx-biker
Waze Global Champs
Waze Global Champs
 
Posts: 2628
Joined: Sat Oct 01, 2011 5:43 am
Location: Germany, Austria and Switzerland (DACH)
Has thanked: 382 times
Been thanked: 377 times

Re: [Script] Highlights for Segments & Landmarks - v1.6 Feb

Postby svx-biker » Fri Feb 22, 2013 2:56 pm

iainhouse wrote:It's an editor problem - nothing to do with the script.


Yes, thanks!

I just found it has been reported already. Given the different scripts I've installed I usually track them down first.

;)
svx-biker
Waze Global Champs
Waze Global Champs
 
Posts: 2628
Joined: Sat Oct 01, 2011 5:43 am
Location: Germany, Austria and Switzerland (DACH)
Has thanked: 382 times
Been thanked: 377 times

Re: [Script] Colour Highlights for Segments - 1.7.4 Nov 2013

Postby svx-biker » Mon Dec 30, 2013 4:03 pm

Atuuu wrote:2) filter roads (landmarks) by country, as I have problem (not the first time) when 10km and even more from Latvia/Estonia border primary country is wrong. Maybe there are some segments with wrong country what could cause this and such functionality could be VERY useful.


Mainly Landmarks are quite hard to find and they have an impact even in the lowest zoom level. If I have some landmarks with wrong country (often shown as "no address") the chat goes into that country even if miles away from the border.

Edit: If you need an area to see/test what I mean here you go: Zoom=0 east of Zürich (Switzerland). You see lots of forest landmarks and some of them seem to be allocated to Germany. That's why you'll find yourself in the chat for Germany instead of Switzerland. Landmarks are selectable even in Zoom=0.

Here is a permalink with such a landmark selected: Landmark with Country Germany
svx-biker
Waze Global Champs
Waze Global Champs
 
Posts: 2628
Joined: Sat Oct 01, 2011 5:43 am
Location: Germany, Austria and Switzerland (DACH)
Has thanked: 382 times
Been thanked: 377 times

Re: [Script] Colour Highlights for Segments - v1.6.7 Jul 201

Postby Szata76 » Fri Jul 19, 2013 1:54 pm

Hi!

Congratulation for making this useful extension. I'm using it often.

What is the difference in these versions for Chrome?
- http://userscripts.org/scripts/show/141050 / Ver. 1.6.7
- http://waze.cryosphere.co.uk/scripts/wm ... ights.html / Ver. 1.67

Why are two different? The "Average speed for segment" works only the second one.

Thanks!
Hardware: LG G3 (D855) / OS: 5.0
Editor level: 5; Area: Magyarország / Hungary
feedthe.waze.hu: Country Feed Manager (Roadworks reporting)
facebook.com/waze.hu ● google.com/+WazeHUN ● wiki.waze.hu
Szata76
Waze Local Champs
Waze Local Champs
 
Posts: 1226
Joined: Fri Jun 10, 2011 5:07 pm
Location: EU, Hungary, Budapest
Has thanked: 165 times
Been thanked: 265 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: No registered users