[Script] WME Validator 2019.09.24 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, JustinS83, Glodenox

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby ispyisail » Fri Jun 20, 2014 10:45 am

olestas wrote:I on the other hand try to minimize scan area, because editor starts lagging horribly :D


You edit and scan at the same time?

I've got slow internet so I don't even bother, I just go away for 5 - 10 minutes
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby ispyisail » Fri Jun 20, 2014 8:13 pm

olestas wrote:Editors lags by itself if fullscreened higher then 1280x1024, even on strong pc for me. Tried running it on 1920x1200 and it lags.. So I have manually strech browsers window to smaller part of screen.. Then it works very fast. I hate when editor lags... Cannot work then :D


Good tip

I maximise for full scan then minimise to edit and fix, might try a smaller edit windows now :)
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby ispyisail » Fri Jun 20, 2014 8:15 pm

ispyisail wrote:I suspect that validator is missing some errors?

Is this possible?

If so could my slow internet have something to do with this?


Im even more sure that its missing problems.

I assume that the tile loads then gets scanned then validator moves on to the next tile. How does validator know the the tile has fully loaded? Time or other?
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby ispyisail » Fri Jun 20, 2014 8:57 pm

Ok i've found an example

This is my report

https://dl.dropboxusercontent.com/u/120 ... wnload.htm

This is the segment that it didn't find

https://www.waze.com/editor/?zoom=5&lat ... =191911646

but it found the ones next to it? (see report)

[ img ]

The scan is with dual screen at full resolution
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby ispyisail » Fri Jun 20, 2014 9:07 pm

When I scan above the problem segment at a lower zoom level it finds it?

https://dl.dropboxusercontent.com/u/120 ... 281%29.htm
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby ispyisail » Sat Jun 21, 2014 9:35 pm

In this particular case Validator missed a note reported by Toolbox. When I looked into the code, both Toolbox and Colour Highlight did not detect tile load properly and they both used a timer to periodically re-highlight segments.


I've done some more tests and I think with a high probability the problem is to do with using dual screens.

When I go to single screen it appears to pick up everything?
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.3 / 04.08.2014

Postby ispyisail » Wed Aug 06, 2014 7:08 pm

iainhouse wrote:
berestovskyy wrote:
iainhouse wrote:Could we please have the highlighting of dead-end u-turns turned back on for the UK, please?

I guess you can still use a custom check for that (i.e. match deadEndA&UturnA or deadEndB&UturnB).

Let me know if you still would like to get those checks back for UK.


Yes please. I wouldn't ask, except I know you already have the infrastructure for making checks country-specific.

Also, I'm already using both custom checks and constantly resisting the temptation to ask you to add more. :lol:


New Zealand wants the same as the UK

Thanks
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.3 / 04.08.2014

Postby ispyisail » Sat Aug 09, 2014 9:24 pm

No, not yet anyway, as this goes against staff's express wishes. So far I believe the UK is the only country to get any sort of special permission from staff to leave them off.


Can you link to any reference for this?

I just want to go through the logic

and the reason why wazeHQ thinks it OK for the UK?
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.0.3 / 04.08.2014

Postby ispyisail » Sun Aug 10, 2014 5:59 am

redviper26 wrote:
Dave2084 wrote:
This whole conversation is at odds with the understanding the UK Champs have regarding dead end U-Turns.

The UK Champs asked Waze to run a job a few months ago which disabled every dead end U-Turn in the UK. It soon became evident that (misguided) users would enable them again and re-introduce the routing errors that come with them since the Waze client has no U-Turn instruction. This is one of the reasons (if not the main reason) behind the disabling of U-Turns on a dead end node in WME.



The situation in the UK is unique, and we did disable U-turns there following the community's request. For other countries, U-turns should be left as they are, and we intend to enable them in the future.

Thanks,

Noam


I'm trying to get a handle on this "U" Turn thing

Currently WME hides the current state
[ img ]

Editors in the UK where enabling all u turns on dead ends (like this but dead end)
[ img ]

UK Waze champs asked for bulk change dead ends (like this but dead end)
[ img ]

New Zealand has been disabling the U turns for dead ends for many months (Like the UK) and as a guess 95% (maybe greater) are now disabled. From my understanding we are in exactly in the same position as the UK.
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

Re: [Script] WME Validator 1.1.1 / 30.08.2014

Postby ispyisail » Wed Sep 10, 2014 5:36 am

It began the auto-scan but only got through one or two tile sets before locking up.


+1
New Zealand and Papua New Guinea Country Manager
[ img ][ img ][ img ]
ispyisail
Waze Local Champs
Waze Local Champs
 
Posts: 3367
Joined: Tue Feb 21, 2012 11:59 pm
Location: New Zealand
Has thanked: 564 times
Been thanked: 567 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Google Feedfetcher, jm6087, Mythdraug, trunkenbold