[Script] WME Validator 2020.04.12 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 2018.08.01 (BETA)

Postby jangliss » Thu Aug 02, 2018 9:50 pm

turbomkt wrote:
Olestas wrote:No more GF version? Only market?


https://greasyfork.org/en/scripts/1571-wme-validator


I get an error that reports the script has been deleted with that link. Is it correct? I did some quick searching on GF and found https://greasyfork.org/en/scripts/370783-wme-validator which appears to be the right one, but I'd rather the author(s) update the link, and correct the front page as well.

Cheers!
jangliss
State Manager
State Manager
 
Posts: 177
Joined: Tue Jul 13, 2010 9:56 pm
Location: Plano, TX
Has thanked: 119 times
Been thanked: 97 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby jarkaz » Fri May 27, 2016 7:27 pm

I wrote to him, but did not even read the message.


Wysłane z iPhone za pomocą Tapatalk
jarkaz
Waze Local Champs
Waze Local Champs
 
Posts: 3235
Joined: Tue Apr 08, 2014 5:04 pm
Location: Sochaczew, Poland
Has thanked: 922 times
Been thanked: 534 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby jarkaz » Fri May 27, 2016 8:58 pm

I wrote in another case, but I just see that the message read;)
jarkaz
Waze Local Champs
Waze Local Champs
 
Posts: 3235
Joined: Tue Apr 08, 2014 5:04 pm
Location: Sochaczew, Poland
Has thanked: 922 times
Been thanked: 534 times

Re: [Script] WME Validator 2019.08.16 (BETA)

Postby jarkaz » Fri Aug 23, 2019 7:58 pm

berestovskyy wrote:v2019.08.16:
- jangliss: Fix for layer refresh if layer did not trigger update
(This fixes compatibility with WME Toolbox)

This is the correct abbreviation, "kpt. Wilhelma Kosińskiego" according to our hash table. Abbreviation tables in wazeopedia: https://wazeopedia.waze.com/wiki/Poland/Tabela_skr%C3%B3t%C3%B3w
Permalink to place: https://www.waze.com/pl/editor/?env=row&lon=20.24565&lat=52.22956&zoom=6&segments=254724307
Screenshot: http://prntscr.com/owpw4w
Please add to Validator
jarkaz
Waze Local Champs
Waze Local Champs
 
Posts: 3235
Joined: Tue Apr 08, 2014 5:04 pm
Location: Sochaczew, Poland
Has thanked: 922 times
Been thanked: 534 times

Re: [Script] WME Validator 0.9.8 (BETA) / 15.04.2014

Postby javanesse » Sun Apr 27, 2014 6:22 am

any updates from this script?
javanesse
 
Posts: 1
Joined: Sun Apr 27, 2014 6:19 am
Has thanked: 0 time
Been thanked: 0 time

Re: [Script] WME Validator 0.8.1 (BETA) / 08.03.2014

Postby Jay91150 » Sun Mar 09, 2014 12:00 am

Since 0.8 I have noticed the validator is reporting quite a few more "overlapping segments" in my area. Was something changed? These are segments that are on/off ramps for highways, and follow the satellite map (and the actual position of the lanes in real-world) correctly.

Also, and I don't have a permalink example of this right now but I'll try to find one sometime soon.. in the past few days I seem to be able to get the validator to go into a kind of a loop, especially if part of a segment is off-screen. I get a "same endpoints drivable segments" warning, so I split the segment in two by drawing a new road to it, then erasing the road. Once I save that, the validator script then reports "Unneeded node" on the node that was just created. Remove the node, and I go back to the "same endpoints" warning again, etc.

Edit: That didn't take long. Validator reported this as "unneeded node B" in the report, but didn't identify it when I clicked the link. I remember having broken this segment into two a few days ago to get rid of the "same endpoints" warning.
Jay91150
 
Posts: 385
Joined: Thu Jan 23, 2014 8:01 pm
Location: Bragg Creek, Alberta, Canada
Has thanked: 98 times
Been thanked: 92 times

Re: [Script] WME Validator 0.9.0 (BETA) / 20.03.2014

Postby Jay91150 » Fri Mar 21, 2014 2:07 pm

pumrum wrote:Wy ==> Way


I did a quick peruse through the available checks, and didn't see anything for non-abbreviated street suffixes in the US, such as:

Road ==> Rd
Street ==> St

Would there be value in adding these for the US servers (I see some for Pl, etc)


For what it's worth, "Wy" is a valid abbreviation of Way in Canada.

There are also some places where road "types" are included in the name. I have one particular area of insanity which is called "View Road Place". (Nearby is "West Rock Road", which should be abbreviated to "West Rock Rd", but is invariably considered the west portion of "Rock Rd", i.e. "W Rock Rd".) In addition, some cities in my province (Alberta) have small stub roads off of streets, which they call xx Street Close, xx Street Crescent, etc.
Jay91150
 
Posts: 385
Joined: Thu Jan 23, 2014 8:01 pm
Location: Bragg Creek, Alberta, Canada
Has thanked: 98 times
Been thanked: 92 times

Re: [Script] WME Validator 0.9.2 (BETA) / 22.03.2014

Postby Jay91150 » Sun Mar 23, 2014 12:27 am

Using the default configuration, the script reports items which start inside my area of responsibility but end outside. An example link is https://www.waze.com/editor/?zoom=4&lat ... s=59779373, but I don't know what good it will do for someone who's not got my same areas of responsibility. The segment's northern end is inside my area, but the problem (at node A) is outside my area. Validator identifies it for me, even though I can't resolve it.

While I'm posting.. I imagine this may have been discussed before, but is there a way to get the script to validate without me staying in that browser tab? If I move to another tab, the script acts as if it's paused.

Also, can the default settings be changed in future releases so that sounds are off? With all due respect, do people really want to listen to their machine beep for 5 minutes while it finds map problems?
Jay91150
 
Posts: 385
Joined: Thu Jan 23, 2014 8:01 pm
Location: Bragg Creek, Alberta, Canada
Has thanked: 98 times
Been thanked: 92 times

Re: [Script] WME Validator 0.9.2 (BETA) / 22.03.2014

Postby Jay91150 » Sun Mar 23, 2014 12:40 pm

berestovskyy wrote:Validator reports issues outside of my editable areas
Please make sure "Exclude non-editable segments" filter option is checked.


It is, and I still get this behavior. I guess it's the "off the screen" part of the issue as some of these segments are very long and end up 3 or 4 "screens" away from the origin point at the max zoom level.
Jay91150
 
Posts: 385
Joined: Thu Jan 23, 2014 8:01 pm
Location: Bragg Creek, Alberta, Canada
Has thanked: 98 times
Been thanked: 92 times

Re: [Script] WME Validator 0.9.3 (BETA) / 25.03.2014

Postby Jay91150 » Wed Mar 26, 2014 4:35 pm

At (a) certain zoom level, when I click on a node (in preparation for doing a 'qw' to fix soft turns, reverse connectivity, etc), the node appears only "partially" selected, and doesn't put anything in the left sidebar of WME except "One node selected" (the "turns allowed" and a button to disable/enable all turns is there, but greyed out). This happened in WME 1.5 and is continuing in WME 1.6. It appears to be zoom level 3, and the icon that indicates the node is selected shows up as a dark blue circle with a translucent (very faint) blue inside, instead of the white circle with light (opaque) blue within. Just wondering if that is related to Validator or if I should be looking at Junction Node Fixer (which I also have installed), or if it's an issue with WME itself.

At zoom 3, I can still see Street level roads, but can't click their segments, so it may be WME instead of Validator, but I thought I'd ask anyway.
Jay91150
 
Posts: 385
Joined: Thu Jan 23, 2014 8:01 pm
Location: Bragg Creek, Alberta, Canada
Has thanked: 98 times
Been thanked: 92 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: AquaZR1, jm6087, SirGadwall