[Script] WME Validator v2021.3.5 (+ PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.1.10 / 05.11.2015

Postby karlcr9911 » Fri Nov 06, 2015 3:51 am

Would be much better as a tab IMO. Having it where it currently sits will cause me to no longer use this script. I'm sure better things are to come and this was a quick fix to get this back functional and that is appreciated as I know a ton of editors use this great script.
Regional Coordinator - U.S. South Central
iOS Beta Leader / Beta Tester | WME Beta Tester
[ img ][ img ][ img ][ img ] [ img ][ img ][ img ]
SCR Wazeopedia
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2464
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 642 times
Been thanked: 1607 times

Re: [Script] WME Validator 1.1.10 / 05.11.2015

Postby karlcr9911 » Fri Nov 06, 2015 4:46 am

Fredo-p wrote:Just how often do you guys use the tabs? I rarely click on them.


I switch between tabs all the time when editing.
Regional Coordinator - U.S. South Central
iOS Beta Leader / Beta Tester | WME Beta Tester
[ img ][ img ][ img ][ img ] [ img ][ img ][ img ]
SCR Wazeopedia
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2464
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 642 times
Been thanked: 1607 times

Re: [Script] WME Validator 1.1.14 / 17.11.2015

Postby karlcr9911 » Fri Dec 11, 2015 10:33 pm

It's flagging it since those letters are not cardinal directions so periods are not technically needed.

And yes, the board attachment issue has been ongoing for a week + now. You can use imgur or something similar to upload your image there and then paste the [img] code here.
Regional Coordinator - U.S. South Central
iOS Beta Leader / Beta Tester | WME Beta Tester
[ img ][ img ][ img ][ img ] [ img ][ img ][ img ]
SCR Wazeopedia
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2464
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 642 times
Been thanked: 1607 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby karlcr9911 » Wed Apr 20, 2016 8:05 pm

It doesn't show up for me at all in Chrome in the newest WME beta release.
Regional Coordinator - U.S. South Central
iOS Beta Leader / Beta Tester | WME Beta Tester
[ img ][ img ][ img ][ img ] [ img ][ img ][ img ]
SCR Wazeopedia
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2464
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 642 times
Been thanked: 1607 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby karlcr9911 » Sat May 28, 2016 6:38 pm

It's a known issue that Validator isn't working in this latest WME release. The script writer has been contacted. If he chooses to update it, he'll do so as soon as he has time.
Regional Coordinator - U.S. South Central
iOS Beta Leader / Beta Tester | WME Beta Tester
[ img ][ img ][ img ][ img ] [ img ][ img ][ img ]
SCR Wazeopedia
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2464
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 642 times
Been thanked: 1607 times

Re: [Script] WME Validator 1.1.19 / 04.06.2016

Postby karlcr9911 » Wed Jun 22, 2016 3:11 pm

When something is highlighted and then fixed, the highlights do not disappear until after you click on the segment/segments that were fixed. In previous versions, once an item was fixed, Validator would immediately remove the highlights.

Chrome on OS X Yosemite
Regional Coordinator - U.S. South Central
iOS Beta Leader / Beta Tester | WME Beta Tester
[ img ][ img ][ img ][ img ] [ img ][ img ][ img ]
SCR Wazeopedia
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2464
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 642 times
Been thanked: 1607 times

Re: [Script] WME Validator 2018.11.10 (BETA)

Postby Kartografer » Mon Dec 10, 2018 4:08 pm

The current version is in the US Wazeopedia, but the language is the same. I'll admit, I wasn't clear on whether one-way roads could exhibit this problem, but I according to Mike they do. I always just fix them anyway.
[ img ]
Galaxy S9 running Pie on Mint
SM Ohio, AM New Mexico, South Dakota
Wazeopedia projects
Then you will know the truth, and the truth will set you free.
-John 8:32
Kartografer
Wiki Master
Wiki Master
 
Posts: 1182
Joined: Wed Dec 23, 2015 2:32 pm
Location: Westerville, Ohio, USA
Has thanked: 551 times
Been thanked: 773 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby KB_Steveo » Tue Jul 22, 2014 12:01 am

I noticed some freeway segments that had an Automatic (1) lock that Validator did not pick up. They were not highlighted nor did they show up in a validator report. I dove into the settings and noticed that this check is set to active with the US default custom rules. I know it was working before this change. Is this something I can fix on my end?
[ img ][ img ][ img ]
WI State Manager
NE Wisconsin Area Manager (Green Bay / Appleton / Sturgeon Bay)
Wisconsin mapping resources curator
KB_Steveo
 
Posts: 318
Joined: Wed Jan 25, 2012 5:26 pm
Location: Wisconsin
Has thanked: 57 times
Been thanked: 29 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby KB_Steveo » Tue Jul 22, 2014 12:02 am

Taco909 wrote:Non beta here and I'm getting similar "buglets" in the display.
The report seems to catch things, but I'll be at a wider view and might see a blue highlight, zooming in it changes to yellow, or something goes away completely.
Clicking the segment displays the errors properly.
I've also noticed that sometimes a couple of days after I've worked an area, I'll see more errors. Pulling up the segment shows no recent edits, so it was something that Validator missed before.

Doesn't bug me a whole lot... right now I'm using Validator as a tool to clean up some major errors in a fairly wide area that has been neglected, so there is still plenty of work to be done even if a few excess nodes are missed here and there.
+1
[ img ][ img ][ img ]
WI State Manager
NE Wisconsin Area Manager (Green Bay / Appleton / Sturgeon Bay)
Wisconsin mapping resources curator
KB_Steveo
 
Posts: 318
Joined: Wed Jan 25, 2012 5:26 pm
Location: Wisconsin
Has thanked: 57 times
Been thanked: 29 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby KB_Steveo » Fri Jul 25, 2014 3:19 pm

berestovskyy wrote:
KB_Steveo wrote:I noticed some freeway segments that had an Automatic (1) lock that Validator did not pick up. They were not highlighted nor did they show up in a validator report.

A permalink?

I locked them, so I just changed this one to automatic. I was playing around, changed it to 1 -> purple highlight, change it to Automatic (1) -> highlight goes away.
https://www.waze.com/editor/?env=usa&lo ... s=56653678
[ img ][ img ][ img ]
WI State Manager
NE Wisconsin Area Manager (Green Bay / Appleton / Sturgeon Bay)
Wisconsin mapping resources curator
KB_Steveo
 
Posts: 318
Joined: Wed Jan 25, 2012 5:26 pm
Location: Wisconsin
Has thanked: 57 times
Been thanked: 29 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: BenEnmen, bz2012, Mapman44, Mythdraug