Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.


Post by yjanayas
Friend, thank you very much for updating this valuable tool.
Greetings from Bogotá, Colombia. :D
BellHouse wrote:Toolbox 1.8.6 is released for Chrome and Firefox:

Code: Select all

1.8.6  (20180530)
Fix: Bugfix of the many selection based issues after WME update. Toolbox popups had to be temporarily disabled to achieve this quickly (#436, #439)
Fix: Display of TTS override icons was broken (#440)
Fix: Tuned some timing issues when creating Toolbox tab upon Toolbox startup (#441)
Update: Added FP closure request link for Spain (#438)
Update: Updated country rights settings for Bermuda and Malaysia
yjanayas
Waze Mentor
Waze Mentor
Posts: 346
Has thanked: 688 times
Been thanked: 270 times

Post by yjanayas
Good morning,
what is " PB / WT " ?
Thank you.
JDraaijer wrote:With Soft-Turns enabled, the Toolbox currently highlights PB/WT nodes that have the new ghost WT node.

https://thumb.ibb.co/i6eViT/2018_06_08_11_17_12_Waze_Map_Editor.png
When a PB/WT is connected to a drivable segment, you can change this by Q/W shortcuts, but WME doens't show the controles when selecting a node.

https://thumb.ibb.co/h39ViT/2018_06_08_11_16_46_Waze_Map_Editor.png
https://thumb.ibb.co/fAjwOT/2018_06_08_11_18_41_Waze_Map_Editor.png
Except when there is a PB/WT crossing, then it can't be changed.

I don't that we need to change the soft-turns of non-drivable segments, but someone can interpret it when enabled in the toolbox.

Is there a reason that the toolbox highlights these nodes?
yjanayas
Waze Mentor
Waze Mentor
Posts: 346
Has thanked: 688 times
Been thanked: 270 times


Post by yjanayas
Thanks Bellhouse :D
BellHouse wrote:
n4dog wrote:...and also the fix RevCon button is no longer working :(
Yup, that has the same cause as the currently malfunctioning Q key, will be fixed in the next release.
yjanayas
Waze Mentor
Waze Mentor
Posts: 346
Has thanked: 688 times
Been thanked: 270 times

Post by YanisKyr
I might have spotted another little issue - size and the position of the "Copy segments attributes" pop-up is forgotten.

It resets to the default size and appears at the top left of the tab.

YanisKyr
Posts: 550
Has thanked: 304 times
Been thanked: 78 times

Post by YanisKyr
Is anyone looking after the Country Permissions sub-forum? :ugeek:

From #1:
YanisKyr
Posts: 550
Has thanked: 304 times
Been thanked: 78 times

Post by YanisKyr
@iainhouse would it be possible to add a link to Prod WME in this section?

When in Beta, I often find myself copying the permalink and replacing the beta bit of the URL manually to jump back to Prod.

YanisKyr
Posts: 550
Has thanked: 304 times
Been thanked: 78 times

Post by YanisKyr
RussPA wrote:That same Toolbox button that switches to beta while in prod switches to prod while in beta.
In beta, that option setting will say "Waze prod editor".
Mind blown :mrgreen: :mrgreen:

YanisKyr
Posts: 550
Has thanked: 304 times
Been thanked: 78 times