Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by Sapozhnik
After last update of WME  :cry:
 

Sapozhnik
Waze Global Champs
Waze Global Champs
Posts: 858
Answers: 3
Has thanked: 24 times
Been thanked: 96 times
Andrey,
Ukraine Waze Coordinator, GC, CM, Beta, ...
http://waze.com.ua

Post by Sapozhnik
Hey,

Anybody has problem with Road Layer? It always switched on after reload of page and it doesn't depends on settings in SVL. 
I  switch off it but it works only till reload of page, 
version v5.2.1

Bedo2991 is it possible add function export|import settings of SVL  to GDrive?
 
Sapozhnik
Waze Global Champs
Waze Global Champs
Posts: 858
Answers: 3
Has thanked: 24 times
Been thanked: 96 times
Andrey,
Ukraine Waze Coordinator, GC, CM, Beta, ...
http://waze.com.ua

Post by Sapozhnik
If yes, you have to check the SVL > Rendering Parameters > SVL Initially Disabled checkbox, save the settings, and then reload.
That seems to work for me.
Yes. This parameters doesn't work for me and some people who I asked.  But RussPA answered that this is WME BUG.

About the settings, do you mean through WazeWrap or with another method? I've never done it.
I don't know how, I'm not scriptwriter. I only asked you  :)
But I think it could be very convenient for sync between different PC
 
 
Sapozhnik
Waze Global Champs
Waze Global Champs
Posts: 858
Answers: 3
Has thanked: 24 times
Been thanked: 96 times
Andrey,
Ukraine Waze Coordinator, GC, CM, Beta, ...
http://waze.com.ua

Post by SeveriorumPatrem
Two requests for editors using devices with limitations on screen resolution (or limitations on visual acuity who choose to use lower resolution so they can see what they're doing):

1. Can we find a different place to put the link to open the settings control panel, or find an alternate way to open it? With lower screen resolution, even without this script in play, in some locales the imagery copyright notices already run into and through the scale bar and lat/long, and the link to open the settings is pushed into unreachable space. Current workaround is to move the active editor view to someplace known to have a shorter strong of copyright notices.
Picture1.jpg
(13.55 KiB) Downloaded 498 times
2. Can the settings window open a little higher on the screen, or can the settings window be movable? On this device, when it opens, the bottom edge gets pushed off the bottom of the screen.
Picture2.jpg
(30.66 KiB) Downloaded 490 times
Thanks for your consideration!
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.

Post by SeveriorumPatrem
Thanks, this reveals the limitations of my understanding of coding and design, I understand now that this shouldn't occur if the base setup from Waze didn't suffer from (another) design oversight.

That said, design flaws in WME are ubiquitous, and have everything to do with why we have and depend upon so many scripts. I don't have high hopes that Waze will soon (or necessarily ever) fix the copyright notice formatting to the ideal state, so the problem for some will remain. It is for that reason that I made the request. If some aspects of a script are inaccessible due to poor native design by Waze (in this case the link to open Street Vector Layer settings), isn't it the nature of script writers to work around and overcome those flaws, instead of waiting for Waze to fix something to its ideal state?
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.

Post by SeveriorumPatrem
Upon additional rumination, maybe this is a fix request that should be directed to FixUI.... if there is a way to resolve the copyright string issue with a script.....

EDIT: And so I went over there to post about it and see that Glodenox already did. :D 8-)

Change request for Street Vector Layer summarily withdrawn.
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.

Post by SeveriorumPatrem
Has anyone else noticed behavior where imported SVL settings don't take effect until the WME refresh button is clicked after the import?
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.

Post by SeveriorumPatrem
I posted some time ago about imported settings not taking effect until a refresh was done. No one else was having that? Even then, those settings were lost the next time you did a browser tab refresh.

Now I've hit a point where imports won't take at all.

This is just me, really?

Would love some troubleshooting help if someone could tell me where to look.
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.

Post by SeveriorumPatrem
Already confirmed it to be failing with all other scripts disabled - but I've failed to take that step before so I appreciate the reminder!

Just discovered that it is apparently the format of my saved settings causing the problem. Saving a new text string and reloading it works fine. I've run into that before when Notepad had Word Wrap enabled, but ruled out this time. I'm left to guess that a script update changed the import/export format ever so slightly somehow?

Unrelated, but repeating a previous request, per the screenshot below, to either make the options control box smaller, movable, or resizable, since even on moderate resolutions it runs off the bottom of the screen and there's nothing you can do about it.
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
Attachments
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.

Post by SeveriorumPatrem
I'm having an issue where SVL is placing a black line down the center of every segment on WME. I hunted everywhere before I found this to be the source, and the only way I was able to clear it up was to reset to the default colors, but then changing literally any SVL setting at all puts the black line down the center of every segment again.

Tested and verified with all other extensions and scripts disabled.

Help?
SeveriorumPatrem
State Manager
State Manager
Posts: 1156
Has thanked: 612 times
Been thanked: 518 times
https://s.waze.tools/s1000.pnghttps://s.waze.tools/c5s.pnghttps://billingtons.net/waze/banner.pngimages/ranks/BetaTester_Badge.pnghttps://s.waze.tools/beta.png
The Grumpy Dad
WA SM - NE SM - Erie County NY AM - Coos County NH AM
The more I learn, the more I discover how much I don't know.